Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

Style & CSS


Accueil

Accueil CHM


ELECTRONIQUE THEORIQUE: LES AMPLIFICATEURS A TRANSISTORS

C3 LES AMPLIFICATEURS PETITS SIGNAUX

        C3.1 Généralités
        C3.2 Les impédances et le gain d'un étage amplificateur
        C3.3 L'importance de la commande
        C3.4 Les trois montages fondamentaux à transistors
        C3.4.1 Montage émetteur commun (EC)
        C3.4.2 Montage base commune (BC)
        C3.4.3 Montage collecteur commun (CC)
        C3.5 Les transistors à effet de champ (FET ou MOS-FET) en amplification
        C3.6 Amplificateur à amplificateur linéaire intégré ou amplificateur opérationnel
        C3.6.1 Montage suiveur
        C3.6.2 Montage amplificateur non inverseur
        C3.6.3 Montage amplificateur inverseur
        C 3.6.4 Montage sommateur
        C 3.6.5 Montage soustracteur

C3.1 Généralités
Dans les circuits électroniques, les étages appelé amplificateurs sont présents pratiquement à tous les endroits de n'importe quel système, à savoir :
    • Dans les étages d'entrées afin d'amener très vite le signal utile à des valeurs exploitables pour le traitement que doit subir ledit signal.
    • Dans les étages intermédiaires pour précisément traiter le signal tout en conservant une amplitude de signal utile exploitable.
    • Dans les étages de sorties pour délivrer aux connexions une amplitude répondant généralement à une norme, et juste avant les étages de puissance

L'analyse des différents montages amplificateurs proposée ici fait appel en premier lieu à une considération générale par un schéma de principe, puis à une analyse un peu plus détaillée par des exemples de montages à transistors ou à amplificateurs linéaires intégrés (amplificateurs opérationnels ou amplis OP).

Nous pouvons avoir en tête la règle qui dit que tout circuit électronique nécessite une alimentation continue pour pouvoir effectuer un traitement de signal entre l'entrée et la sortie. Les montages amplificateurs ont besoin d'une alimentation continue la plus stable possible et surtout totalement indépendante du signal qui transite.
Les pages sur les alimentations donnent les détails sur les différents circuits de l'alimentation continue. Toutefois, toute analyse de montage amplificateur passe par la lecture verticale au sujet de l'alimentation DC et ensuite par la lecture horizontale qui traite du passage du signal entre l'entrée et la sortie. Les schémas de principes sur les montages amplificateurs qui suivent traitent du passage du signal uniquement.
Pour débuter, nous pouvons admettre q'un montage amplificateur possède toujours deux bornes d'entrées et deux bornes de sorties et possède trois caractéristiques principales représentées par le schéma général :

L'impédance d'entrée Z e : Elle permet de savoir quelle sera la puissance du signal d'entrée nécessaire au bon
          fonctionnement du montage amplificateur.
L'impédance de sortie ZS : Elle permet de savoir quelle sera l'adaptation nécessaire pour les étages suivants.
Le gain en tension Au : Il permet de savoir quelle sera la différence d'amplitude apportée au signal entre l'entrée
          et la sortie.
Toute analyse d'un montage amplificateur servira à connaître ces trois caractéristiques pour déterminer le suivi d'un signal et un éventuel dysfonctionnement.

C3.2 Les impédances et le gain d'un étage amplificateur
Dans un appareil électronique, le signal traverse successivement différents étages qui ont chacun une fonction différente. En complétant le schéma précédent :

Le passage d'un étage à l'autre met en évidence le rôle des impédances Ze pour la résistance interne Rig du montage précédent et ZS pour la résistance de charge Rch du montage qui suit.
La modification de la valeur de ces trois caractéristiques peut varier en fonction de la fréquence du signal, dans le cas de filtres passe-haut, passe-bas, ... Ou alors, cette modification permet au montage d'avoir une fonction d'adaptateur d'impédances, de régulateur d'amplitude, d'amplificateur de courant, etc.
En pratique, nous rencontrons très souvent une borne commune à l'entrée et à la sortie. Cette borne commune est un point de référence pour le signal. De ce fait, le schéma équivalent du montage devient:

En guise de rappel :
Si Ri << Rch ==> Générateur de tension
Si Ri = Rch ==> Générateur de puissance
Si Ri >> Rch ==> Générateur de courant

Le générateur de puissance est également appelé générateur adapté. Il permet le transfert du maximum de puissance du signal. C'est notamment nécessaire lorsque le signal disponible est particulièrement faible comme dans les étages d'entrées ou de réception hautes fréquences.
C3.3 L'importance de la commande
Il est toujours questions du type de sa commande lorsque nous parlons d'un étage amplificateur. Nous parlons de commande en tension ou en courant, ce qu'évoque le rappel ci-dessus. La commande est importante à double titre.
D'une part, le rapport Ri / Rch est important pour le fonctionnement de l'étage amplificateur.
Si la Rch représente en fait une impédance d'entrée d'un amplificateur, nous pouvons parler d'une commande en tension si Ri << Rch et d'une commande en courant si Ri >> Rch. Nous pouvons le représenter par les schémas équivalents suivants:

D'autre part, le choix de la commande en courant ou en tension est dépendant de la nature de l'étage qui suit. Pour alimenter un circuit de puissance inductif comme des haut-parleurs, il faut des amplificateurs de courants comme le sont les transistors par exemple.
Pour l'amplification de petits signaux, la succession d'étages amplificateurs et atténuateurs (filtres, volumes, etc.) est généralement nécessaire. Pour garder un maximum de fidélité, notamment dans les graves et les variations brusques, l'important réside au niveau des porteurs de charges commandés dans les étages d'entrées.
Les transistors bipolaires, avec eux tous les amplificateurs opérationnels et tous les IC linéaires + TTL, nécessitent la mise en route des électrons de diffusion (P ou N). Il faut commander un courant, soit le courant de base Ib. Même s'il est souvent négligeable, le retard qu'il entraîne en fait le point faible, avec la puissance de commande Ue × Ie, de ces montages. Leurs grandes qualités sont leur souplesse d'emploi et leur robustesse.

Les transistors à effet de champ (JFET ou MOSFET) ont eux l'avantage d'avoir une très grande résistance d'entrée et nécessitent une tension de commande uniquement pour influencer un champ électrique à l'intérieur d'un isolant, électrodes appelés grille (ou gate).
Ils ne consomment aucun courant (en dehors des courant thermoélectroniques) et n'ont besoin que d'une tension de commande. Ils rappellent en cela les amplificateurs à tubes et présentent les avantages d'une très grande rapidité de "réaction" ce qui amène une meilleure fidélité notamment en reproduction sonore (signal audio).

C3.4 Les trois montages fondamentaux à transistors
Pour un montage amplificateur à transistor, l'électrode reliée à la borne commune donne le nom au montage. Nous parlons d'un montage émetteur commun EC, base commune BC ou collecteur commun CC. Chacun de ces montages à ses caractéristiques propres.
Pour reconnaître le nom du montage dans un schéma, il faut repérer de quelle manière le signal est appliqué et quelle est l'électrode reliée, directement ou par découplage, à la masse. Le schéma équivalent AC confirme à l'évidence le type de montage utilisé.
Le procédé pour l'obtention du schéma équivalent AC est décrit sur les pages du site d'introduction à l'électronique "A3 Modélisation - schémas équivalents". Ci-dessous un exemple de trois circuits possédant une même alimentation en courant continu DC (= même polarisation)

C3.4.1 Montage émetteur commun (EC)
C'est le montage le plus universel car il permet un bon gain en tension et en courant avec des impédances d'entrée et de sortie moyennes.

C3.4.2 Montage base commune (BC)
Ce montage possède une faible impédance d'entrée et peut travailler assez haut en fréquences. Nous le rencontrons souvent en premier étage amplificateur des récepteurs radios FM.

C3.4.3 Montage collecteur commun (CC)
Ce montage est également appelé émetteur suiveur car son gain en tension est voisin de 1 (uS @ uE). Par contre, il est utilisé comme abaisseur d'impédance ou comme amplificateur de courant.

L'analyse en courants continus de ces trois montages permet de mettre en évidence qu'il s'agit de la même polarisation appelée polarisation classique ou par diviseur de tension de base. Les procédés de calculs sont donnés dans l'annexe C3.1.
L'analyse en courants alternatifs met en évidence le rôle des condensateurs de liaisons et de découplage représentés ci-dessus par des condensateurs polarisés. Les procédés de calculs sont donnés dans l'annexe C3.2.
Le calcul des fréquences limites des montages amplificateurs à transistors sont développés dans l'annexe C3.3.
Pour les trois montages amplificateurs à transistors fondamentaux, nous pouvons accepter le tableau récapitulatif suivant:

MONTAGE EC

MONTAGE BC

 MONTAGE CC
DEPHASAGE 180 degrés 0 degré 0 degré
GAIN AU
GAIN AI
GAIN AP
Grand
Grand
Très grand
Grand
env. 1
Grand
env. 1
Grand
Moyen
IMPEDANCE ZE
IMPEDANCE ZS
Moyenne
Grande
Petite
Très grande
Grande
Petite
UTILISATION
* amplificateur
universel
* ampli HF
* oscillateur
* élévateur
d'impédance
* oscillateur
* amplificateur
de courant
* abaisseur
d'impédance

Il est possible de rencontrer, dans certaines documentations, des caractéristiques de transistors exprimés en paramètres h, utilisés anciennement. Le tableau ci-dessous la signification de ces paramètres.

PARAMETRES | SIGNIFICATION | CONDITION
h11e =hie [W] | Impédance d'entrée | Sortie en court-circuit
h12e = hre | Taux de contre-réaction interne | Entrée ouverte
h21e = hfe | Gain en courant | Sortie en court-circuit
h22e = hoe [S] | Admittance de sortie | Entrée ouverte

Relevons encore que les paramètres h varient en fonction de la température, des courants de repos et des signaux qui transitent dans le montage.

C3.5 Les transistors à effet de champ (FET ou MOS-FET) en amplification

Le signal qui transite dans les montages amplificateurs à FET, comme pour les transistors bipolaires, représente des petites variations des tensions et courants autour du point de repos Q.
Le cas ci-contre du MOS-FET le démontre bien. La polarisation nulle entraîne un courant de drain de repos IDQ, et le signal fait varier ce courant.
La variation du courant de drain est récupérée en variation de tension aux bornes de la résistance de drain RD.
A l'image des montages à transistors bipolaires, le schéma équivalent AC d'un montage à FET permet de déterminer ses caractéristiques. Nous rencontrons des montages Drain commun, grille commune ou source commune.
Le grand avantage de ces transistors réside dans le fait qu'aucun courant de grille n'est consommé, ce qui donne une impédance d'entrée très élevée (RG valant facilement quelques méghoms). Le gain en tension vaut approximativement AU @ RD / RS et l'impédance de sortie prend la valeur de RD.

L'exemple du montage ci-dessous est un amplificateur audio complet dont "l'étage final" est réalisé avec deux transistors MOS-FET, schéma présenté dans la revue ELECTOR du mois de décembre 1993.

C3.6 Amplificateur à amplificateur linéaire intégré ou amplificateur opérationnel

Dès 1965, l'intégration des éléments électronique (diodes, transistors, etc.) à permis la réalisation d'un circuit électronique complexe réalisant la fonction d'un amplificateur petits signaux.
Ces amplificateurs sont désignés dans la pratique de l'électronique comme un élément intégré appelé "Amplificateur opérationnel" ou "ampli OP". C'est un élément électronique comprenant deux entrées et une sortie :

Pour que l'ampli OP réalise sa fonction, il doit nécessairement être alimenté en courants continus, il lui faut une alimentation continue, généralement réalisée par une alimentation fractionnée (V+ et V-). L'alimentation ne figure pas sur le symbole simplifié ci-dessus, elle est sous-entendue.
Les amplis OP ont des caractéristiques quasi idéales par rapport aux montages à transistors bipolaires ou à effet de champ. Nous pouvons accepter pour un ampli OP les caractéristiques idéales suivantes :

ZE @ infini (1MW) AU @ infini (100 000) ZS @ nulle (75W)

Ces caractéristiques idéalisées nous permettent de simplifier considérablement la compréhension ainsi que les calculs des montages contenant des amplis OP. En effet les propriétés du montage dépendront uniquement des éléments extérieurs reliés à l'ampli OP (résistances; condensateurs; etc.).
Actuellement, dans la très grande majorité des appareils et installations électroniques travaillant avec des petits signaux nous rencontrons des circuits intégrés désignés sous ampli OP. Nous pouvons dire sans trop d'erreurs que les amplificateurs opérationnels sont les composants de base des montages électroniques analogiques modernes.

C3.6.1 Montage suiveur

Les caractéristiques pratiquement idéales d'un ampli OP permet un usage multiple de ce composant intégré. Afin de déterminé s'il est utilisé en amplificateur petits signaux, il suffit de repérer s'il existe une connexion entre la sortie et l'entrée inverseuse de l'ampli. L'exemple le plus caractéristique est l'amplificateur suiveur car la connexion est directement réalisée par un fil.

Le gain en tension de ce montage est égal à l'unité AU = 1. Ce qui signifie que l'amplitude du signal est la même à la sortie qu'à l'entrée uS = uE. De prime abord ce montage est inutile puisque nous avons le même signal, mais c'est oublier le rôle des impédances.
Les impédances d'entrée et de sortie sont celles de l'ampli OP seul, à savoir l'ordre du Mégohm pour ZE et de 75W pour ZS. Ce qui permet de disposer d'une puissance de signal beaucoup plus grande à la sortie qu'à l'entrée.
Ce type de montage est très souvent utilisé lorsque le signal d'entrée est issu d'un capteur ou lorsque il ne faut pas trop "charger" l'étage précédent.

C3.6.2 Montage amplificateur non inverseur
Un amplificateur non-inverseur se défini par un dispositif dont le potentiel de sortie Vs est proportionnel au potentiel d'entrée V1. Le coefficient de proportionnalité Au, appelé amplification en tension en boucle fermée, est positif.

Vs = Au . V1 pour -VSAT < Vs < +VSAT

Le schéma de principe d'un ampli OP non-inverseur est :

Nous obtenons un amplificateur non-inverseur en réinjectant sur l'entrée négative de l'A.O. une partie V's de la tension de sortie Vs avec un diviseur de tension formé des résistances R1 et R2.
L'expression de la fonction de transfert
Vs = f (V1) s'obtient en exprimant l'égalité des courants dans les résistances et en admettant que :
    Fonction de transfert : Propriétés du montage :
La résistance d'entrée du montage est quasi infinie et par conséquent ce montage ne charge pas la sortie de l'étage qui le précède.
La résistance de sortie du montage est très petite; plus faible que l'impédance de sortie de l'ampli OP seul, grâce à la contre-réaction de tension appliquée à l'Ampli OP.
L'amplification en tension Au est constante (elle ne varie pas) dans la zone d'amplification et dans une plage de fréquence donnée.
La gain en tension vaut Au = 1 + R2 / R1
Ce montage se comporte comme un amplificateur de tension idéal dont le gain Au est choisi par la valeur des résistances R1 et R2 uniquement.

C3.6.3 Montage amplificateur inverseur

Un amplificateur inverseur se défini par un dispositif dont le potentiel de sortie Vs est proportionnel au potentiel d'entrée V1 mais inversé de 180°. Le coefficient de proportionnalité Au, appelé amplification en tension en boucle fermée, est négatif.
        US = AUBF x UE pour -VSAT < Vs < +VSAT

Le schéma de principe de l'ampli OP inverseur est:
Nous obtenons un amplificateur inverseur en réinjectant sur l'entrée négative de l'Ampli OP une partie de la tension de sortie Vs à travers la résistance R2.
Le signal V1 est injecté dans le montage à travers la résistance R1. L'entrée positive de l'Ampli OP est reliée directement à la masse(*).

L'expression de la fonction de transfert Vs = f (V1) s'obtient en exprimant l'égalité de la valeur des courants dans les résistances R1 et R2 mais sans oublier que ces courants sont de signes opposés. La tension d'entré V1 se retrouve aux bornes de la résistance R1 et la tension de sortie Vs aux bornes de la résistances R2.
      Fonction de transfert : Propriétés du montage inverseur :

La résistance d'entrée du montage est égale à la résistance R1 par le fait que le potentiel à l'entrée inverseuse ne varie pas.
Nous parlons d'une mise à terre virtuelle (ou masse virtuelle) de l'entrée négative de l'Ampli OP.
La résistance de sortie du montage est grande, plus grande que celle de l'ampli OP seul, par la contre-réaction de tension appliquée à l'Ampli OP.
L'amplification en tension Au est constante (elle ne varie pas) dans la zone d'amplification et dans une plage de fréquence donnée.

Le gain en tension du montage Au = R2 / R1

Le montage se comporte comme un adaptateur d'impédance facile à réaliser.
(*)L'entrée positive de l'Ampli OP est parfois reliée à la masse à travers une résistance dont la valeur vaut R2 // R1 afin de réduire la tension de décalage (voir les caractéristiques de l'ampli OP seul).

C 3.6.4 Montage sommateur

Un autre grand avantage de l'amplificateur inverseur est de pouvoir être dépendant de plusieurs entrées simultanément. L'impédance interne de l'amli-OP est tellement grande qu'aucun courant ne la traverse et que le potentiel d'entrée inverseuse reste toujours à zéro volts. C'est ce que nous appelons une masse virtuelle.
Si nous observons l'image ci-contre, nous constatons que la résistance R3 est traversée par la somme des courants traversant R1 et R2.
Pour chaque entrée, les rapports I1 = v1 / R1 et I2 = v2 / R2 sont valables. La tension de sortie se retrouve aux bornes de R3 et devient vo = R3 × I3 = R3 × (I1 + I2).
Le montage agissant sur l'entrée inverseuse de l'ampli-OP la polarité de la tension de sortie sera l'inverse de la somme des tensions d'entrées.
Cela ce traduit par la formule:

En ajustant la valeur des résistance il est possible de régler à la fois le gain total et le niveau de chaque entrée ou de multiplier les entrées pour donner un convertisseur digital - analogique sommaire comme l'illustrent les deux exemples ci-dessous.

C 3.6.5 Montage soustracteur
Chaque entrée du montage est appliqué à une entrée de l'ampli-OP différente. La première entrée agit sur le potentiel de l'entrée non-inverseuse de l'ampli-OP et la deuxième entrée sur celui de l'entrée inverseuse de l'ampli-OP.
Si le rapport des résistances entre la sortie et chaque entrée est identique, alors la tension de sortie vaudra :

La résistance réglable est indiquée ici pour mettre en évidence la possibilité d'équilibrer le montage afin de compenser la dispersion des caractéristiques des composants du montage.
L'exemple ci-dessous d'un amplificateur pour appareil de mesure permet d'imaginer une très grande impédance d'entrée grâce aux montages suiveurs. Le montage soustracteur qui suit permet de rendre la sensibilité de mesure beaucoup plus grande.
L'utilité du réglage de la résistance R1 (appelée CMRR (=taux de réjection en mode commun)


Usine AUDAX 1953


two transistor tone control circuit

tone control circuit using IC741

power supply et un mixer passif

baxandall tone control circuit

Tone control circuit

Baxandall Tone Control

baxandall tone circuit

baxandall circuit et C.I. Aop

BAXANDALL à TUBES

Baxandall

baxandall circuit calculator

baxandall poles and zeros calculator

baxandall bass and tone circuit

Example graph

buffer ed baxII


Tone

Vu dans ... http://members.optusnet.com.au/batwingsoup/builds/tone.htm

Three pot, Bass Middle & Treble tone controls that are used on my Blackheart BH5.

From left to right the pots are Bass, Middle, Treble and Volume.
The signal comes in at the join where the 100k resistor and 470pf silver-mica capacitor meet.
The other end of the silver-mica capacitor joins the left pin(photo), top pin(schematic) of the treble pot.

The centre pin of the Treble pot is where the signal goes out to the volume pot,
The centre pin of the volume pot is where the signal goes out to the next stage.

The Black wires go to ground.
The other side of the 100k resistor goes to the two .022 capacitors,
The .022 capacitors connect to the bass and mid pots,
with the left and centre pins of the bass pot tied together.

This same circuit is shared by other amps with changes to only some of the part values. (highlighted in red)

 | Blackheart BH5 C2 - 470pf C3 - .022uf C4 - .022uf R5 - 100k Treb - B250k Bass - A1M Mid - B25k | Marshall Plexi C2 - 470pf C3 - .022uf C4 - .022uf R5 - 33k Treb - B250k Bass - A1M Mid - B25k | Mesa boogie V-Twin C2 - 500pf C3 - .022uf C4 - .022uf R5 - 100k Treb - B200k Bass - A1M Mid - B25k | Marshall Class 5 C2 - 470pf C3 - .047uf C4 - .022uf R5 - 68k Treb - B200k Bass - A1M Mid - B20k
Slightly different circuit shared by Fender Twin and other amps with changes to the part values. (highlighted in red)
 | Fender Twin C2 - 250pf C3 - .1uf C4 - .047uf R5 - 100k Treb - B250k Bass - A1M Mid - B10k | Fender Blues Deluxe C2 - 250pf C3 - .1uf C4 - .022uf R5 - 100k Treb - B250k Bass - A1M Mid - B25k | Mesa boogie Lonestar C2 - 250pf C3 - .1uf C4 - .047uf R5 - 100k Treb - B250k Bass - B250k Mid - B10k |

Two pot, Bass & Treble tone controls
There are minor variations to the three pot tone circuit. Some leave out the Mid control, replacing it with a fixed resistor.

The Baxandall tone stack

Commonly found in hi-fi designs usually centred around a midrange frequency of 1KHz, while most guitar amp tone circuits are centred around a midrange frequency from 300hz to 500hz. With Fender-type stacks the bass and treble knobs mostly just boost, and the mids knob mostly just cuts. So in that case having all of the knobs at "noon" actually creates a scoop of the mids. They can't provide a true mid boost, they are used in many guitar amps because most guitarists prefer midrange cut, and don't need the apparent midrange boost the Baxandall provides. Many amp builders have used the Baxandall tone stack in guitar amps with pleasing results. The Baxandall tone stack is featured in Duncan Amp’s Tone Stack Calculator under the name “James”.

Single pot tone controls

Fender “Brownface” treble cut cap .01uf treble lift cap 500pF silver mica
Fender “Tweed” treble cut cap .0047uf Sprague Orange Drop 715P treble lift cap 500pF silver mica

Connect the left pin of vol pot to the middle pin of tone pot. Connect the silver mica capacitor from the middle pin of vol pot to the left pin of tone pot. Connect the .01uf capacitor from the right pin of the vol pot to the right pin of the tone pot, then from here to ground.
Marshall “Plexi” treble cut cap .01uf treble lift cap 500pF silver mica

The centre pin of the volume pot (red wire on the EVJ) is where the signal goes out to the next stage. Connect the centre pin of volume pot to the centre pin of tone pot. The left pin of the volume pot (white wire on the EVJ) is where the signal comes in. Connect the silver mica capacitor from the left pin of tone pot to the left pin of volume pot. Connect the .01uf capacitor from the right pin of the tone pot to the right pin of the volume pot, then from here to ground (black wire on the EVJ).
Marshall “18 Watt”


The James-Baxandall Passive Tone-Control Network

Vu dans ... http://makearadio.com/tech/tone.htm

The James-Baxandall Passive Tone-Control Network

Independent adjustment of bass and treble frequencies in high fidelity audio amplifiers is usually accomplished utilizing specially designed tone-control networks. There are versions for these tone controls based only on passive components, such as the ground-referenced James network shown in fig. 1. Among those versions using active devices we must make mention of P.J. Baxandall´s proposal, in which the tone control was devised as a feedback amplifier (refs. 1 and 2).

In this article we shall analyze the James network (also known as the passive Baxandall tone control), obtaining its design equations.

Let´s begin studying the bass control section (fig.2), which has influence over the frequencies below the designed center frequency of the overall James network.

Here, R4 offers some isolation between this stage and the treble control section (frequencies above the center frequency are affected by this control). R5 represents the input resistance of the amplifier connected to the output of the James network and should be selected such that it imposes no appreciable load on the network. Here we assume that C3 and C4 are open circuits at the bass frequencies.

With full bass boost (R2´s slider at the upper end), the equivalent circuit for the tone control is as depicted by fig.3.

From this figure and knowing that “s” is Laplace´s variable, we obtain:

where:

Then:

After some algebraic work we arrive to:

...(1)

The gain for high bass frequencies is:

The gain at low frequencies is:

Expression (1) has a zero given by:

and a pole:

With the tone control adjusted for maximum bass cut (R2´s slider at the lower end), the equivalent circuit changes to that of fig.4. Again, we neglect the loading effect of R4 and R5.

Now the following holds:

A simple algebraic manipulation takes us to:

...(2)

The gain at high bass frequencies is now given by:

For low frequencies the gain is:

Expression (2) has a zero given by:

and a pole:

The gain ratio at low frequencies is:

For a 40dB control range the following relationship must be satisfied:

...(3)

Then:

On the other hand, at maximum bass boost, the ratio of the gains for low and high bass frequencies is:

According to expression (3):

Then:

For a 20dB bass boost:

Solving for R1 we arrive to the following relationship:

We may check that:

this is, the ratio of the high-frequency and low-frequency bass gains is also 20dB at maximum bass cut.

For best symmetry in the response curves we must choose s01 = sp4. Therefore:

Substituting the already obtained relationships between the resistances yields:

Then, C2 = 10C1.

The corresponding Bode plot of the bass response at full boost and full cut is shown below.

Next, we will analyze the treble control. We have already stated that the treble frequencies are those above the center frequency for which the James network is designed. We may consider C1 and C2 as short circuits at these frequencies. Therefore, R1 and R3 along with R4 are part of the treble network (fig.6).

In order to facilitate calculations, we shall first find the Thevenin equivalent for Vg, R1 and R3. In fig.7, the equivalent Thevenin voltage source, V1, is given by:

...(4)

The equivalent Thevenin resistance, RTH, is:

With the treble control adjusted for maximum boost (R6´s slider at the upper end), and assuming the current through resistor R6 is much smaller than that flowing through R4, we may state the following:

if R5>>R4.

Substituting the value given by expression (4) for V1:

Rearranging this equation we get:

Then:

...(5)

At sufficiently low treble-frequencies:

the same as -20.83dB.

At sufficiently high treble-frequencies:

or 0dB.

Expression (5) has a zero given by:

and a pole:

With the treble control adjusted for maximum cut (R6´s slider at the lower end) we may write:

Then:

From the above equation and bearing in mind (4):

...(6)

At sufficiently low treble-frequencies:

or -20.83dB.

At sufficiently high treble-frequencies:

Expression (6) has a pole given by:

For best symmetry in the response curves we must choose sp7 = s05. Therefore:

yielding C4 = 11C3.

Fig.8 shows the corresponding Bode plot of the treble response at full boost and full cut.

A convenient value for R6 must now be computed. We need some knowledge on the constraints the network imposes before we may neglect the current through R6, as compared to that circulating through R4 (IR6<<IR4). IR4 is given by the following expression when the treble control is adjusted for full cut:

and IR6 by:

Therefore, the requirement that must be satisfied is:

The worst case for the above inequality occurs when s approaches infinity. Translated to our analysis, at sufficiently high treble-frequencies. Then, it is required that:

or equivalently:

At sufficiently high frequencies:

It is clear then that the following must be satisfied:

Then:

...(7)

If we conduct a similar analysis when the treble control is at full boost, we would find that the condition to be met is R6>>1.1R4. Hence, expression (7) prevails.

We would like to arrive at easy-to-use design formulae, so, before presenting a design example for the James network we shall try to simplify the expressions for f01, fp2, f03, fp4, f05, fp6 and fp7. First, for convenience, the relationships between the components’ values will be repeated. These are:

R1 = 10R3

R2 = 99R3

C2 = 10C1

C4 = 11C3

f01 is given by:

...(8)

fp2 is given by:

...(9)

f03 is given by:

fp4 = f01, required for the desired symmetry on the response curves.

f05 is given by:

...(10)

fp6 is given by:

fp7 = f05, required for the desired symmetry on the response curves.

The center frequency of the James network is taken as the geometric mean of f01 and f05, this is:

...(11)

which coincides with the frequency of the minimum of the amplitude response curve when the bass and treble controls are at full boost. Agrees also with the frequency of the maximum of the amplitude response curve when both controls are at full cut. Usually, 1kHz is adopted as the center frequency.

A Design Example

Let us suppose we wish to design a tone control for a transistorized piece of equipment. An adequate value for R1 is 10k ohms. R3 will then be a 1k ohm-resistor and R2 a 100k ohm-potentiometer (standard value).

It is convenient that f01 and f05 be separated one decade in frequency. Then, from expression (11) we may obtain that:

Being fc = 1kHz, we find that f01 must be 316Hz. The value for f05 will then be 3.16kHz.

From expression (8) we obtain for C2 a value of 503.65nF. Then, C1 should have a capacitance of 50.36nF. According to (9), fp2 = 31.6Hz.

R5 is taken equal to 5 times R2 in order to avoid loading effects on the bass network. Therefore, R5 = 500k ohms. R4 must be chosen such that an affordable value for R6 is obtained when using inequality (7). If we make R4 = 5k ohms, then R6 must satisfy the condition R6>>65k ohms. We may adopt a value of 500k ohms for R6.

From expression (10), with the value chosen for R4 we obtain C3 = 774.85pF and C4 = 8.52nF.

Finally, in order to avoid additional attenuation in the circuit, the output resistance of generator Vg (source resistance) must be made some 20 times smaller than R1.

Simulation of the frequency response of the James network

Tone Stack Calculator 1.3 is an excellent software program that can be used for simulation of tone-control networks. It may be downloaded from:

http://www.duncanamps.com/tsc/

Two simulations have been made using this program. The first simulation uses the above calculated component values and the second one, standard capacitor values for the circuit. No major variation on frequency response has been observed between them. Simulation results are shown below.

Fig.9 Frequency response of the James network with the bass and treble controls at full boost (upper) and full cut (lower).

Fig.10 Frequency response of the James network when standard capacitance values for C1, C2, C3 and C4 are used.

References

1. Baxandall, P.J. “Negative feedback tone control – independent variation of bass and treble without switches” W.W. 58.10 (Oct. 1952) 402. Correction 58.11 (Nov. 1952) 444.

2. Vargas Patrón, Ramón “Red activa de control de tono”

http://www.inictel.gob.pe/publicaciones/rvargas/red-activa.htm

Ramon Vargas Patron

rvargas@inictel.gob.pe

Lima-Peru, South America

July 23rd 2004


Practical Tone Controls.

Vu dans ... http://www.angelfire.com/electronic/funwithtubes/Amp-Tone-A.html

Designing and Building
Audio Amplifiers.

Practical Tone Control Circuits.

I have lately found that there is a lot of interest in tone control circuits. It's beginning to seem as if 2/3 of the earth's surface is covered by water and the remaining 1/3 is covered with diagrams of tone controls. Although I have covered this topic under the heading of "Audio Amplifiers, How they Work" the circuits on that page are not intended to be duplicated by the reader and there is virtually no information on how and where to insert them into an amplifier. This page will attempt to rectify that situation.

Powering Your Tone Control.

Before we get to the tone controls themselves a question arises "how to power the electronics in a tone control circuit?" I often receive emailed questions on this subject. I have concluded that it is advisable to include a power supply schematic on this page.

There are alternatives to building a standalone power supply. The current required is small ranging from 1 mA for the least to 7 mA for the maximum at a voltage of 250 volts DC. The ac requirement is 6.3 volts at 600 mA at most. A few power amplifiers have auxiliary power sockets for just this purpose. If the DC voltage is not right don't worry. As someone once said, tubes are forgiving. The circuits are specified to need 250 volts but they can operate anywhere from 200 to 350 volts and in some cases they will do just fine on 150 volts. (Note: Remember this when looking for a transformer for one of the circuits below.)

Failing an auxiliary power socket you can also go into a power amplifier or preamplifier and steel a small amount of power. Because power amplifiers have power to spare you are not very likely to cause an overload by obtaining power from this source. This may not be true for a preamplifier which itself may not need very much power. In any case you should not try this unless you know what you are doing.

So, you don't feel competent to modify your power amplifier. Or you fear a modification might reduce its resale value. In any case you have decided to build a power supply for the tone control circuit. Let's begin with the schematic.

Figure 0 Schematic Diagram of Two Possible Power Supplies.

Component Ratings.

The two 1 k ohm resistors are 1 watt. The two 100 ohm resistors are 1/2 watt. If your transformer comes with a center tap on the 6.3 volt secondary you may omit the two 100 ohm resistors and connect the center tap to the minus H V. All three capacitors have a voltage rating of 350 volts. You could use 450 volt caps if you have them on hand. These values are sufficient to reduce hum to inaudible levels and I recommend against going higher. The diodes are 1000 volt 1 amp such as the 1N4007. You probably won't be able to find 25 mA transformers so don't worry about going higher. The voltage may be hard to find depending on where you buy transformers. It's ok to go 35 volts lower or 70 volts higher. If you go higher on the voltage you should definitely use 450 volt capacitors.

Construction.

If you are going to build the tone controls and power supply on the same chassis be sure to place the transformer and primary wiring as far away from the amplifiers as possible. Also build some shielding into the chassis. If you are planning to build an entire preamplifier and switcher the power supply can cause real problems. In the past I have built Heathkits in which the power supply section was encased in a steel box for magnetic shielding as well as electrostatic. Because aluminum is not magnetic it will not shield against magnetic fields.

Where should tone controls be placed?

The answer to that depends on whether you are building or modifying an integrated amplifier or a preamp that is used with a separate power amplifier or monoblock power amplifiers. Also there is no one correct answer and there can be many variations on the theme and no one can definitely say that some of them are wrong. However, there are a few don'ts and they will be pointed out.

Volume and Balance Placement.

Although I have seen it done in commercial semiconductor amplifiers I don't recommend placing the volume and balance pots one after the other in a tube amplifier. Figure 1 below shows what I am talking about.

Figure 1 Diagram Showing Parasitic Capacitance Associated
With Volume and Balance Controls.

In my ill-informed youth I did connect a balance control pot right after a volume control. The loss of highs was obvious so I never did that again.
Due to its construction a pot has quite a lot of stray capacitance to ground. This is indicated by the capacitor in red in the diagram of Figure 1. The highest impedance is seen at the wiper when the control is set to half resistance.
Note. An audio taper pot has 10% resistance at half rotation. The half resistance point for such a pot is near the top, somewhere between the 3 o'clock and 4 o'clock positions.
When 10 k ohm pots are used, as in transistor amplifiers, this is not a problem. I measured a typical pot to have a capacitance to its case as 30 pf. Two pots together would have 60 pf and add another 90 pf for shielded wiring and tube capacitance and you have 150 pf. If two 500 k ohm pots are used the corner frequency is 10,600 cycles. Remember that is the -3 dB point. The response will be down by 1 dB at 5,500 cycles. That would give it a clearly audible and objectionable effect. There should always be at least a tube stage between the volume and balance controls.

Tone and Volume or Balance controls.

Can we place the tone and another level control pot, volume or balance, next to each other? Well, that depends. An active tone control, I'll define that later, by definition includes tube stages so it wouldn't matter. A passive tone control, no tubes, would be another story. Such a circuit with two pots and wiring to and from them is going to present a lot of capacitance, easily 150 pf. That lets out putting a passive tone control after a volume or balance control. What about placing volume or balance after a passive circuit? Lets take a look at that.

Figure 2 Passive Tone Control.

Whether we can place a pot with its own capacitance plus wiring capacitance after a passive tone control depends on the output impedance of the tone circuit. Because of the many capacitors in the circuit its output impedance is going to change a lot with frequency. But because high frequency roll-off is what we are concerned with, the high end is what we need to look at.

Consider the circuit of Figure 2. When the treble control is set flat, center of rotation it will present 50 k ohms between wiper and CCW end. So from the output to ground we have 50 k in the pot and a 0.0033 uf capacitor. The capacitor has 4.8 k ohms of reactance at 10,000 cycles so the resistance of 50 k ohms is mainly it.

Remember that an audio taper pot has 10% resistance at the center of rotation.
Over on the bass side there are two capacitors across the pot. The 0.018 uf across the bottom half of the pot will effectively short it out at 10,000 cycles. So the impedance to ground caused by the bass part of the circuit is 27 k ohms in series with 33 k ohms which adds up to 60 k ohms. The output impedance is the parallel combination of 60 k and 50 k which is 27.2727 k ohms, lets call it 27 k ohms. This resistance when combined with 150 pf gives a roll-off frequency of 39,300 cycles. The amplitude will be 1 dB down at 20,000 cycles. I have been deliberately pessimistic with the amount of capacitance so the effect should not be audible even to very young golden ears. Figure 3 is the graph of the frequency response with 50 picofarads of capacitance connected across the output. This is a simulation not the measured results from a real circuit.

Figure 3 Frequency Response of Circuit in Figure 2.

Source Selector.

Obviously you don't want the tone control to effect just one source or want to have a separate tone control circuit for each source. Same goes for volume and balance. The source selector always comes first.
I can almost hear someone thinking "Hmmm. Separate tone, volume, and balance for each source. That could have some real advantages." It would, but you had better design your preamp with a big panel with lots of room for the controls. My preamp has 12 inputs. If you take away 2 for internal test signal generator and SCA decoder that still leaves 10.

Volume and Balance Controls.

Usual practice is to place the volume control right after the source selector although There is no reason not to do it differently. The usual rationalization is to be able to reduce the signal level right away to prevent overloading early stages. This design procedure was developed more than 50 years ago when input sources might not have been as well standardized as they are today. I can see definite advantages in putting the balance and tone controls ahead of the volume control. Lets look at a few block diagrams shown in Figure 4.

Figure 4 Three Alternative Block Diagrams of Preamp or Integrated Amplifier.

Block diagram (a) is the standard one and is in fact used in the Harmon Kardon A-300. The tube amplifier after the balance control is the first tube in the global feed back loop. This design could also be used in a stand-alone preamp because it ends with a tube amplifier which could include a cathode follower or two stage circuit with feedback to obtain a low output impedance.

Diagram (b) has the volume and balance controls interchanged. The balance control may have anywhere from 0 to 6 dB of attenuation depending on what balance circuit you plan to use. Look at balance circuits to find out more. These circuits are presented with values and enough information to make them usable in DIY projects. Any tubes that are between the balance and volume controls, including those in an active tone control, if used, must be designed so as not to overload at the highest signal level from any source.

Figure (c) could be used in an integrated amplifier in which the amplifier right after the tone control would most likely be the first stage in the global feedback loop. If it were used in a stand-alone preamp the tone control would have to be an active one or another tube stage would have to be added.

A preamp has to be connected to the power amplifier with shielded cables. These have a lot of capacitance to the tune of 30 or 40 pf per foot. A 3 foot cable could have 120 pf of capacitance and this is not highly pessimistic. To avoid having a corner frequency of less than 100 kc the output impedance would have to be less than 13 k ohms.

Passive Tone Control.

A passive tone control is defined as a network of resistors, some of them variable, and capacitors, that will function properly as a tone control in the absence of any amplifying device. Something else that distinguishes a passive tone control is the use of audio taper controls. This is very important. If you use linear controls you will find that the bass and treble are boosted and you will only get it to flat by setting the controls at 1/10 of their rotation. The cut will be in the remaining 10% of rotation.

The Baxandall tone control circuit above fits this definition. We have already established that it's output impedance is low enough to drive a somewhat capacitive load without audible roll-off. Its input impedance would be about 190 k ohms, worst possible case at the high end. Any tube would not have any difficulty driving this impedance.

Modified Harmon Kardon Circuit.

In the original HK amplifier the circuit diagram shows no resistor between the two wipers of the bass and treble pots. The circuitry is inside one of those packaged circuits but a test with an ohmmeter shows zero resistance between the two wipers. This is what is responsible for a rise in the low band around 200 cycles. I added the 33 k ohm resistor to bring it into compliance with what most people expect from this type of circuit. See Figure 2 above.

The passive tone control has very close to 20 dB of attenuation when set flat. The output voltage will be 1/10 of the input voltage. This is because resistors and capacitors alone can't provide any bass or treble boost. When boost is cranked in the bass or treble is attenuated less. The ideal case would be to precede this tone control with an amplifier that has exactly 20 dB of gain as shown in Figure 5 below.

Figure 5 Passive Tone Control with Makeup Amplifier.

Figure 6 Frequency Response of Circuit of Figure 5.

The simulator steppes the bass and treble pots together in 10 dB steps. For example in a 500 k ohm audio taper pot, which most of the circuits use, the tone flat point is with the wiper at 50 k ohms which is 10% or 20 dB down from fully clockwise. This setting is always the center one, of the 5 curves on the graph. The one below flat is 15.8 k ohms and the bottom one is at zero. Above the flat curve the setting is for 158 k ohms and the top curve is fully clockwise, 500 k ohms.

The 12AX7 stage has a gain of 10 so the overall gain is unity or 0 dB. The treble range might not seem like much control but the ear is very sensitive to small changes in the treble band and I seldom set the control anywhere near its extreme. The only exception is when I play a 78 RPM record and I turn the treble all the way down. The 270 k ohm resistor became a 200 k because the tube stage has some resistance in its output. I know it should be a 220 k ohm but 200 k gives the flattest response when the bass is set to mid rotation. The simulation was run with 50 pf connected across the output.

The 500 k ohm load on the output is necessary to give a truly flat response at center of rotation. If you are sending the signal from the tone control to an amplifier stage, a 510 k ohm resistor should be placed from grid to ground. This is necessary, for the above reason, even though the Baxandall circuit contains a DC return. If you are placing a volume or balance control after the tone control it should be 500 k ohms and the wiper should go to the grid of a tube with no additional resistors to ground.

RCA Tube Manual Circuit.

Figure 7 Passive Tone Control From RCA Tube Manual.

Figure 8 Frequency Response of Circuit of Figure 7.

Figure 7 is also a passive circuit. The values are quite large and that gives it an increased sensitivity to capacitive loading. That is why it is preceded by and followed by a tube amplifier. Even with that, the natural stray capacitance causes the roll-off you see in the graph below.

If you are incorporating this circuit into an existing preamp you should modify the existing tube circuits rather than adding these amplifiers after and before existing stages. If you are designing from scratch the volume or balance control would go before the first amplifier and the other control after the output stage. As you can see even with the tube to isolate the tone control from capacitive loads the flat curve is rolled off to -3 dB at 20,000 cycles. Personally, I would never use this circuit in an audio project.

Not so many tubes.

If you would like a more robust control than the HK but not so many tubes as the RCA then you can combine them. Take the passive part from Figure 7 and drop it in place of the parts in Figure 5. Now divide all resistor values, pots too, by 2 and multiply all capacitor values by 2. The value closest to 50 k ohms is 51 k ohms. 5 k ohms, 5.1 k ohms. The capacitors should be 0.043 if you can get them. If not, 0.047 uf will have to do. This goes for all of the "22" capacitors. You will have a control with the large boosts and cuts of the RCA circuit but one that will drive the balance or volume control directly without an additional tube circuit.

Inserting a tone control between preamp and power amp.

Do you want a totally passive circuit to connect between an existing setup that is made up of a preamp and a stereo power amplifier or two monoblock amplifiers? Someone who wants to do this likely doesn't want any tubes in the tone control, just a little box with 2 or 4 knobs on it to control the tone.

Many power amplifiers have lots of sensitivity. One I have heard of needs only 0.15 volts to drive it to full power. However, even if yours is specified to require 1 volt for full power you still will have plenty of gain left over. Who plays their amplifiers at full power? Kids in cars do but at home the adults I know have higher regard for the health of their inner ears to do that.

Most preamps are designed very conservatively to drive a long shielded cable. To give it that capability the output impedance is quite low. So it can drive a relatively low impedance circuit. Knowing that we are going to connect the tone control box to the power amp with shielded cable we must give the tone control circuit a low enough impedance so the highs won't be rolled off by the cable capacitance. Figure 9 is one channel of a circuit. The other channel looks exactly like it. The pots may be ganged or separate according to builders taste.

Figure 9 Passive Tone Control for Insertion
Between Preamp and Power Amp.

Figure 10 Top, Frequency Response of Circuit as Shown. Bottom,
Frequency Response Without Fixed Resistors in Treble Arm.

You will notice the addition of two resistors. These will ensure that the treble cut will shelve instead of falling out of site. The top graph in Figure 10 was made with the resistors in place and the lower one with them set to zero ohms in the simulation. It may be argued that it really doesn't make any difference since it all happens above 15 kc. Some people might want to bring the break points of the treble control down to a lower frequency. If this is done, shelving could become important. To lower the treble frequencies increase the values of the capacitors above and below the treble pot. Remember to keep them in a 10 to 1 ratio.

If you find that the bass and treble boost and cut are indeed more than you need you could increase the input impedance by increasing the four fixed resistors that are above and below the bass pot and above and below the treble pot. Make the 10 k a 22 k and the 1 k a 2.2 k ohm. This will reduce the bass boost and cut by 6 dB but it will raise the input impedance to 24 k ohms.

At low frequencies where the value of the output coupling capacitor may become important the tone control will present a higher impedance load because the reactance of the two capacitors across the bass control has increased. The 0.022 uf capacitor has a reactance of 145 k ohms at 50 cycles. The impedance will decrease some as the bass is boosted.

The simulation was run with a capacitive load of 105 pf which would be the approximate capacitance of a 3 foot shielded cable.

Active Tone Controls.

Now we are up to active tone controls. They are defined as needing an amplifier to work properly. They also use linear controls. The advantage of linear controls is they always have half resistance at half rotation. Some audio taper controls do not have 10% resistance at half rotation. With active controls it is easier to be sure that setting the controls to center of rotation will give tone flat. It is still the basic Baxandall circuit but it is in the feedback loop of an amplifier. Transistor designers jumped on this one early on because gain is so easy to come by in a small space as compared to tubes. It is doable with tubes but might require one extra 12AX7 per channel as compared to passive circuits. Many people might say that the improved symmetry of response curves is worth it. I would be inclined to agree.

The Brimar Circuit.

Brimar was the name of a tube manufacturer in England who came up with the circuit shown in Figure 11.

Figure 11 Brimar Tone Control Circuit.

Figure 12 Frequency Response Showing a Flaw.

This circuit looks quite elegant on paper, or computer screen, but the frequency response shows a real problem. Look at the flat gain in the bass portion and compare it with the same curve in the treble region. I imagine this would give the amplifier a rather dim sound, the opposite of bright. The tube on the right has a lot of feedback around it but the one on the left is operating completely open loop and at full gain with a bypassed cathode resistor. The output resistance of this stage is the 100 k ohm load in parallel with the plate resistance of the tube (12AX7) which is 80 k ohms. That works out to 44 k ohms. The graph in Figure 15 below shows how the impedance of a similar circuit varies with frequency. This problem could be cured by adding a cathode follower to each amplifier stage.

In spite of its other shortcomings you will note a much improved symmetry of the frequency response over the open-loop Baxandall tone control. This makes for a much smoother cut and boost as well as identical spectra for both.

The circuit has 33 dB of gain at tone flat and 100 cycles. Removing the cathode bypass capacitor only lowers this figure to 25 dB. That's still a lot of gain to stick into the middle of a preamp. I have never owned a commercial preamp but my design approach would be to give it 10 dB of gain with the volume control set to maximum. The argument being, the output stage should not be driven into clipping even at maximum volume and tone setting. Most sources deliver about 0.7 volts RMS which is about 2 volts peak to peak. 10 dB will increase this to 6.3 volts peak to peak. Granted that's not much for a tube amplifier but if the owner decides to crank in full bass boost at 15 dB more we are up to 35 volts P-P. That's certainly at a level which could increase distortion if not taking it to the point of clipping. So dropping this control into the middle of a preamp would increase the output to a whopping 623 volts peak to peak. If you are still awake you will remember that I put in an initial gain of 10 dB. If we take that out and just have the tone control with the cathode bypass removed, 25 dB of gain from the starting point of 2 volts P-P gives us 36 volts and then the 15 dB of bass boost puts the overall gain at 40 dB which will give 200 volts P-P from our original 2 volts P-P. No matter how you slice it, it seems to be too much gain. A figure of 10 dB gain plus 15 dB of bass boost will give 36 volts P-P from our original 2 v P-P. So I think I'll stick to my 10 dB overall gain figure.

Putting the Baxandall Inside a Feedback Loop.

The curves of the open loop Baxandall circuit may seem a little less than perfect. I would be the first to grant that it probably would be impossible to hear the difference. However, I am somewhat of a perfectionist so it would be nice if a circuit could be developed that behaved better than the passive circuits above. It seems that if we put the passive circuit inside of the feedback loop of an amplifier it will give curves that look much better.

The Principle of an Inverting Amplifier.

To understand how an active tone control works we must digress a little to study inverting amplifiers. The inverting amplifier has several unique features but the one that is important to us is the ability to employ feedback to set it to less than unity gain. The noninverting amplifier can be set to unity by strapping the output to the inverting input. The gain can't be set any lower than that. The inverting amplifier, in Figure 13 (a) below, does not have this limitation.

Figure 13 (a) Showing How Feedback Sets Gain.
(b) Showing Tone Control in Feedback Loop.

In the circuit of Figure 13 (a) , a generalized amplifier has feedback applied from output to inverting input through R2. The input signal is applied through R1. If the gain of the amplifier is large the voltage from the inverting input to ground will be small. That means the currents through R1 and R2 are set mainly by the magnitude of the input and output voltages. If the input impedance of the amplifier is large the current flowing through the input terminal will be very small. Thus we can say that the current in R1 is the same as the current in R2. We can write the equations,

VIN = I1 x R1     and     VOUT = I2 x R2

But,

I1 = I2

Because the currents in R1 and R2 are equal and in the same direction and VIN is on the left end of R1 and VOUT is on the right end of R2 the input and output voltages have to be of opposite signs.

Lets try some simple logic on that one. Now, we must be sure to say exactly what we mean and mean exactly what we say. In part A of Figure 13 above, the term, input refers to the left end of R1. Output refers to the right end of R2 which is also the amplifier output. Inverting input refers to the point where R1 and R2 connect to the amplifier. Remember that the voltage at the inverting input of the amplifier is very small. Lets call it zero for the sake of argument. If you place a positive voltage on the input the only way to get zero at the inverting input is for the output to be negative. The inverting input is a tube grid so it is an open circuit. You can't have both ends of the resistor string be negative and have the middle be zero. They must always be opposites. Now, if the input signal is AC the output will be AC of the opposite phase. And that, Virginia, is why its called an inverting amplifier.

We are going to solve the two equations above for I, since they are equal, and set them equal to each other. But because of the sign difference between input and output we have to sneak in a minus sign.

VIN / R1 = -VOUT / R2

Rearranging gives,

VOUT / VIN = -R2 / R1

Of course VOUT / VIN is the gain. If R2 is larger than R1 the gain will be greater than unity. If R2 is less than R1 the gain will be less than unity.

One more little fact about an inverting amplifier is that the inverting input acts like a low impedance point. If the gain of the amplifier is very high, say one million, the input will act like a dead short to ground. The reason for this is, what ever the input voltage does the output voltage will be adjusted to the opposite sign and the necessary magnitude to keep the inverting input at zero. There is current flowing but no, or very little, voltage and that spells low impedance. In practical operational amplifiers the inverting input point, or summing node, is often referred to as a virtual ground. For more information on the subject of feedback amplifiers refer to Chapters 5 and 6 of my textbook Electronics for Non-Engineers. The book is on another web site so use your back button to return here.

Now look at the schematic of Figure 13 (b) above, in which the Baxandall circuit has taken the place of R1 and R2. Strange as it may seem there is virtually no current flowing in the 15 k ohm resistor or the 6.8 k ohm resistor.* Looking back at part A, the current due to signal is flowing through R1 and R2. There is essentially no current flowing in the vertical line connecting the junction of the two resistors to the inverting input. A resistor could be placed in this line with no measurable effect on the performance of the amplifier. The one restriction would be that the added resistor must be much less than the input impedance of the amplifier. In part B, the input resistance of the amplifier is much greater than the 15 k ohm resistor. At frequencies where the reactance of the 0.001 uf capacitor becomes large the treble control is no longer having any effect so this is of no consequence.

* This statement is true only if the two controls are set to the same point. If there is a difference the circuit becomes more difficult to analyze and we will leave such analysis for another time and place when and where everyone understands how to use the j operator.
The wipers of the pots are at zero potential so if they are set at center, the connection points on the left and right are at the same potential and opposite phase. This is equivalent to R1 = R2 in part A. The gain is unity for all frequencies. If the wipers are moved to the left this is equivalent to R1 growing smaller and R2 growing larger. This will increase the gain but only for lows and highs. The mid range, around 1,000 cycles will be little effected. Moving the wipers to the right of center will cause the gain to be less than unity and the highs and lows will be cut.

If the bass control is moved to the left while the treble control is left at the center, the unbalance will drive current through the 15 k ohm resistor at low frequencies. The effect will be that of decreasing R1 and increasing R2. The gain will be increased for low frequencies. At mid and high frequencies the two 0.1 uf capacitors will keep the circuit balanced, R1 = R2, and the gain for these frequencies will remain at unity.

When the bass pot is returned to center and the treble pot is moved to the left the wiper becomes unbalanced for all frequencies but only the highs are coupled to the inverting input through the 0.001 uf capacitor. A circuit with two capacitors, one on each side of the treble pot performs better and is easier to understand. I have not run a simulation on the circuit in part B so I can't say how well it performs. It could be used with op amps or transistorized gain blocks but it's impedance is too low to be used with tubes. Well, maybe with cathode followers.

A Tone Control You Can Love.

Figure 14 shows the tone control that I think has the best compromise between performance and tube count. Yes Virginia, everything is a compromise. It uses only two triodes per channel, one 12AX7 or your choice of other hi mu triodes, and it has a nice symmetrical looking frequency response curve. Its gain when set to flat is about -1 dB which is close enough to unity to not cause overload problems in a preamp or integrated amplifier. You could transplant the tube stages from Figure 18 below if inclined. The performance would be slightly improved.

Figure 14 Practical Tone Circuit Using One 12AX7 Per Channel.

The pots are linear taper and the center of rotation is tone flat. Moving the wipers to the right on the diagram is cut, which would be the counter clockwise position, and to the left is boost, the clockwise end of the control. All resistors are 1/4 watt although you may use 1/2 watt if you prefer. The 100 k ohm resistor from pin 6 of the 12AX7 should be a 1/2 watt in any case. The 0.47 uf capacitor on the left may have a voltage rating as low as 200 volts but the one on the right should be a 630 volt. The voltage rating of the 0.047 uf depends on what is connected to the input of the circuit. If it is the plate of a tube the voltage should be 630 volt. If the wiper of a pot a 200 volt would be fine. The three capacitors in the tone circuit don't need to be anymore than 50 volts although there is no harm in going much higher if they are all you can get.

Unlike the passive circuit this one uses a single capacitor across the bass pot instead of two from each end to wiper. If this were to be done in a passive circuit setting of the bass control would alter the amount of treble boost or cut. The virtual ground of the amplifier grid effectively isolates the bass and treble circuits and the interaction amounts to about 1/100 of a dB.

This was not done to save capacitors. Connecting two capacitors from wiper to each end causes the resistance in parallel with the capacitor to change as the bass pot is turned. This causes the corner frequency of the bass boost and cut to change depending on the setting of the pot. This effect is clearly visible in Figure 10. Figure 15 looks much better as the breakpoints on the bass curves remain constant regardless of the setting of the control.

Figure 15 Graph Showing Frequency Response, and Drive Impedance of Circuit of Figure 14.

The graph at the bottom in green is k ohms of input impedance of the tone circuit. The measurement was made by inserting a current controlled voltage source in series with the 0.47 uf capacitor on the left. The bottom line is full boost, the next one up is half boost and the highest one to be completely on the graph is flat. Now you can see the reason for the gain variation in the Brimar circuit above. With an impedance of 80 k ohms at 100 cycles and 45 k ohms at 10 kc it's no wonder why a cathode follower is required to drive the circuit. The amplifier on the right would have the same trouble if it didn't have so much feedback around it. It's open-loop gain does change but not enough to cause any significant problems.

Three Band Tone Control? Maybe.

The circuit of Figure 16 was sent to me by a gentleman who asked me to evaluate it for him. It turns out to be useless as a tone control but I am posting it for what it has the potential to become, which is a 10 band graphic equalizer using tubes. Each channel would require 6 and 1/2 12AX7s which may or may not look feasible to you.

Figure 16 Three Band Tone Control? Or Unfinished 10 Band Equalizer?

Moving the wipers to the bottom in the diagram gives full cut and to the top full boost. The 110 k ohm and 120 k ohm resistors should definitely be 1 watt. The two 100 k ohm resistors in the plate of one of the 12AX7s should be 1/2 watt and all other resistors may be as small as 1/4 watt. All capacitors should be at least 200 volt. The frequency determining capacitors aren't exposed to any appreciable voltage during operation but if B- comes up before the tube cathodes are hot, these capacitors would feel 150 volts.

Figure 17 Frequency Response of Each Band and Then All Three.

The first graph shows the effect of setting the low band pot to full cut, half cut, flat, half boost, and full boost. The other two are not changed but left set flat. The second graph shows the effect of the mid band pot with all others held constant and the third shows the effect of the high band pot. The fourth shows all three being changed simultaneously. The equation for the frequency is,

f = 1 / (6 Pi R C)

Where R is the 10 k ohm resistor and C is the value of the capacitors connected to it. The values of capacitors for a 10 band EQ would be as listed below.
Frequency (cycles) Capacitor
Standard Value 		Capacitor
Calculated
31.5 | 0.18 uf | 0.168 uf
63 | 0.082 uf | 0.0842 uf
125 | 0.039 uf | 0.0424 uf
250 | 0.022 uf | 0.0212 uf
500 | 0.01 uf | 0.0106 uf
1,000 | 0.0056 uf | 0.00530 uf
2,000 | 0.0027 uf | 0.00265 uf
4,000 | 0.0012 uf | 0.00133 uf
8,000 | 680 pf | 663 pf
16,000 | 330 pf | 332 pf

A 3 Band Tone Control You Can Love.

The circuit shown in Figure 18 originally came from a book of op amp circuits. I increased the impedance level to make it suitable for tubes and did quite a lot of reengineering on it. The pin numbers on the left hand triode are for half of a 12AU7. If you elect to use a 6C4 the pin numbers will have to be looked up on line or in a tube manual. If you would like to use one less triode per channel you could transplant the amplifiers from Figure 14 above. You might notice a slight reduction in performance. All resistors are 1/4 watt unless otherwise noted. All the capacitors that are associated with tubes are 200 volt. The exception is the 50 microfarad which is a 25 or 15 volt unit. All others can be as low as 50 volt if you can find them that low. The two 1 uf caps and the 0.047 uf cap are the only ones that will have any DC voltage across them. The 0.047 uf cap may need to be a 630 volt if there is another tube stage connected to the input.

Figure 18 Practical 3 Band Tone Control.

Figure 19 Frequency Response of 3 Band Circuit with Controls Set In Various Combinations.

The first of the four graphs above shows the mid band control being adjusted while the bass and treble are left set flat. The second shows the bass and treble being adjusted while the mid band is left flat. The third shows the bass and treble being adjusted while the mid band is set at full boost. The fourth shows the bass and treble being adjusted while the mid band is at full cut. The mid band may not seem to be having much effect but the ear is so sensitive in this frequency range that a little goes a long way. At some time in the past I owned a receiver that had a three band tone control of this type. A friend who owned the same model plotted the frequency response curves of the tone control and they looked very much like these. The mid band control had a clearly audible effect.

Viewer Suggested Modification.

This is a circuit that I took down from this page several years ago but it continued to generate interest in spite of the fact that it requires two 12AX7s for each channel. A gentleman named Jack posted a notice on the Audio Asylum forum that the circuit produced an infrasonic peak around 1 to 2 Hz. He suggested a cure and I have decided to put the circuit back on this site including his suggestion. It is the best performing tone control circuit on this page. The only drawback is the high tube count

Figure 20 Unity Gain Baxandall Circuit.

What makes it perform so well is the low output impedance of both amplifiers. Jack inserted the 1.5 uf cap and 33 k ohm resistor in the grid of the first amplifier. This is inside the NFB loop which causes a low end roll off of 3.2 Hz. This falls between the approximate 12 to 14 Hz set by the 0.0018 uf cap and the bootstrapped 1 meg resistor in the grid circuit of the cathode follower, and, the worst case of the 10 uf cap and the tone circuit, bass at maximum, of 0.72 Hz.

If you would like to use a smaller capacitor the circuit can be scaled. As long as the RC product remains constant the circuit should perform the same. For example a 0.5 uf cap could be used with a 100 k ohm resistor. The capacitor does not need a high voltage rating as there shouldn't be any more than a volt or two DC across it. Jack has not tested different values of resistor and capacitor and neither have I.

It is possible that the extra components could be made unnecessary by decreasing the value of the 0.0018 uf capacitor that connects from plate to grid of the 12AX7. This is something that needs to be looked into. This is not meant to be any criticism of Jack's work. I'm just thinking out loud. Maybe I'll have a chance to do it after I finish my latest breadboard project. See my daily activities page if you are curious.

The three band tone control could probably benefit from use of these amplifiers. It probably should be impedance scaled to use 100 k ohm pots.

This circuit also solves a possible problem that someone on the Fun With Tubes forum recently pointed out. All of the other active tone control circuits shown produce a phase inversion. If someone wants to add a tone flat switch to their project the phase will flip as the switch is flipped. This may or may not be a problem but for those who are concerned that it is this control has no such problem. It incorporates two inverting amplifiers which spells no inversion. A tone flat switch will not have any effect on the phase except at frequencies which have been boosted or cut by the tone controls.

Alternative Amplifier Circuit.

As stated above the amplifier circuits can be switched around from one control to another depending on how much of a perfectionist you are. Figure 20 shows an amplifier circuit contributed by Mike from the Fun with Tubes email list.

Figure 21 Another Set of Amplifiers for Figures 14 and 18.

>

The output stage is borrowed from the phase inverter circuit used in a series of amplifiers found in RCA tube manual RC-28. This gives higher gain than a triode along with low output impedance. The cathode follower keeps the tone circuit from lowering the gain of the amplifier unlike the one used in Figure 14. Using a pentode as the input cathode follower will give a lower output impedance because the tube has a higher transconductance than a triode.

Well, that's about it. I hope this gives you something new to have fun with.


Op-Amps as amplifiers and Tone Controls

Vu dans ... https://www.st-andrews.ac.uk/~www_pa/Scots_Guide/audio/part8/Page2.html

hd2.gif - 14Kb

8·2 Op-Amps as Amplifier Stages
The obvious use of Op-Amp ICs is as signal amplifiers. In general terms these are of four main types. Inverting, Non-Inverting, Differential, and Buffers. We have already discussed some of these in previous sections but figure 8·2 shows a comparison of the required circuits, all using the same basic Op-Amp. It is conventional to call the two inputs Inverting and Non-Inverting depending upon the sign of the resulting output and the gain when a signal is fed to the relevant input whilst the other is connected to zero volts (shown as an Earth symbol). In figure 8·1 [image] was shown entering the non-inverting input and [image] entering the inverting input. It is also conventional to label these inputs with a plus sign for the non-inverting input and a minus sign for the inverting input to indicate the sign of the gain that will be applied to the signal entering via that connection.

Fig2.gif - 27Kb

In each case the behaviour of the amplifier is controlled by the feedback from the output to the inverting input (i.e. the input where [image] is shown to be applied in figure 8·1). Given an Op-Amp with a very high open-loop gain we can expect the voltages at the two inputs to always be very similar when the output is a modest voltage. e.g. If the amplifier has an open loop differential voltage gain of [image] (quite a common value) then when the output is, say, 10 Volts, the two inputs will only differ in voltage by 0·1microvolts.

In a circuit like the Inverting arrangement the non-inverting input is connected to Earth (nominally zero volts) directly. Hence the output always adjusts to keep the inverting input to the Op-Amp at almost zero volts (give or take a few microvolts). Hence the input to an inverting input connection sees a resistance ( [image] in these examples) whose other end is connected to a Virtual Earth, so sees an effective input resistance of [image]. Signals presented to a non-inverting input in the other arrangements see an input which the Op-Amp tends to adjust to almost equal the input. Hence the non-inverting arrangement has a very high input resistance. The output impedance of all the arrangements is very low provided we don’t ask for more current than the Op-Amp can supply since the feedback tries always to assert the output voltage required.

8.3 Filters, Tone Controls, and EQ
Although often used to amplify signals, Op-Amps have many other uses. We have already seen in part 3 how an amplifier with a differential input can be used as part of a active filter. In principle, these active filters are just feedback amplifiers with highly frequency-specific feedback networks that manipulate the closed-loop gain as a controlled function of the signal frequency. in addition to the high/low/bandpass (or band reject) filters outlined in part 3 there are a number of other frequency-dependent functions which Op-Amps can be used to perform. Here we can take the example of Tone Controls circuits sometimes used in audio systems.

Although Tone Controls are now rarely provided in domestic Hi-Fi equipment, they still appear in some professional items and can be very useful in improving less-than-perfect source material. Their main task is to adjust the frequency response to obtain a more natural result. However they can also be useful for special purposes such as deliberately manipulating the sound. In scientific areas beyond Hi-Fi some form of adjustment of the frequency response can be very useful in ‘pre whitening’ the spectrum of a signal. This means boosting some frequencies and attenuating others in order to obtain a spectrum which has a more uniform power spectral density. It allows recording or transmission systems to be used more efficiently and provide an optimum signal to noise performance.

Fig3.gif - 18Kb

The classic form of tone control in Hi-Fi is the Baxandall arrangement shown in figure 8·3. This arrangement is called a Baxandall tone control, named after its inventor. We can understand how it works by noticing that it is actually a development of the non-inverting amplifier arrangement shown in figure 8·2. However the normal pair of feedback resistors have been replaced by quite complicated arrangements of resistance and capacitance. The circuit is laid out in a symmetric manner. In this case the impedance between the signal input and the inverting input of the amplifier is [image] and the impedance between the output and the inverting input is [image]. The voltage gain is therefore now

where both [image] and [image] may be complex and have frequency-dependent values. However if we set both potentiometers to their central positions we find that despite being individually frequency dependent we get [image] at all frequencies. Hence when the pots are centered the frequency response is nominally flat and has a gain of [image]. However if we move either potentiometer setting away from its central position we imbalance the system and produce a value of [image] which varies with frequency.

Consider first the effect of the upper pot (the [image] one). At high frequencies the pair of 47 nF capacitors act as a short circuit and clamp the three wires of this 100k pot together. Hence adjusting the 100k pot does not alter the high frequency behaviour of the circuit. However at lower frequencies the impedance of the capacitors rises and the pot has some effect. Hence the 100k pot acts as a Bass Control and allows us to boost or cut the relative gain for low frequency signals. Now consider the lower pot (the [image] one). Here the effect of the associated capacitors is reversed. The 10 nF capacitors mean that the arm of the circuit which contains the 47k pot essentially loses contact with the input and output at low frequencies. Hence the 47k pot has not effect upon low frequency signals, but it does upon high frequencies. It therefore acts as a Treble Control and can be used to boost or cut the relative gain at high frequencies.

Various forms of Tone adjustment can be applied. For example, the Graphic Equaliser circuits which are popular in studios and PA systems use a bank of bandpass filters to break the signal’s frequency range into chunks. Each frequency section is then amplified and the results added (or subtracted) back together with various controlled gains to rebuild the overall signal. By altering the relative gains of the bandpass filters specific tonal bands can be boosted or cut to alter the sound. These complex circuits do reveal one of the main potential problems of Tonal adjustments. Any slight unwanted imbalances mean that it can be almost impossible to get a flat response should it be desired! For this reason, professional or high quality system use close tolerance components and usually have a ‘defeat’ switch that allows the signal to bypass the entire system when tonal adjustments are not required. Given the good quality of signals that are often available these days, tonal adjustment is usually only of value for special purposes or for reducing the severity of problems with historic recordings, or ones made incorrectly. There is therefore something of a ‘theological’ debate in Hi-Fi as to whether people should have, or use, such systems at all. Purists say not. Realists find them useful. As with most engineering this is a case of “Yer pays yer money and yer takes yer choice”!

Content and pages maintained by: Jim Lesurf (jcgl@st-and.ac.uk)
using TechWriter Pro and HTMLEdit on a StrongARM powered RISCOS machine.
University of St. Andrews, St Andrews, Fife KY16 9SS, Scotland.


Vu dans ... https://sound-au.com/articles/eq.htm

  • Introduction
    • 1 - Fixed Equalisers
    • 2 - Tone Controls For Reproduction
    • 3 - Tone Controls For Production
    • 4 - Basic Tone Controls
    • 5 - Graphic Equalisers
    • 6 - Variable Frequency Tone Controls
    • 7 - Parametric Equalisers
    • 8 - Guitar Amp Tone Stacks
    • 9 - Frequency 'Isolators'
    • 10 - 'Tilt' Controls
  • Conclusions
  • References
Introduction

Equalisation (EQ) is one of the most contentious areas of hi-fi. For many years, it was expected of any preamplifier that it would have (at the minimum) bass and treble controls. There were untold variations of course, but the general scheme that ended up being used by almost all manufacturers was the 'Baxandall' topology, named after its inventor Peter J Baxandall. This arrangement is used to this day, but for audio production (as opposed to reproduction) the equalisation available is much more complex and comprehensive.

The term 'equalisation' probably came from the requirements of various operators (phone, motion picture, broadcast, etc.) to get their systems back to a flat frequency response - in other words to make it 'equal' to the intended signal.

In reality, equalisation (or simply 'filtering' as it was known in the early years) has been part of recording and PA equipment from the beginning of the technology. Western Electric (which eventually became Bell Labs) described filters (equalisers) for the telephone system to adjust the frequency response and correct high frequency rolloff in the telephone lines. Early 'tone' controls were in evidence not long after the advent of AM radio ('wireless' as it was known at the time). These were typically only able to roll off the high frequencies to make the sound more 'mellow' and reduce extraneous noise.

While audiophiles the world over eschew any form of EQ, at least 99% of the recordings they listen to have already been processed with individual EQ on each channel, as well as overall EQ, compression, limiting, and other 'effects' as may be deemed appropriate by the recording and mastering engineers. However, in this article, I will discuss mainly 'user adjustable' equalisation ('equalization' for North American readers).

Mixing desks for recording and live production provide extensive EQ, and no-one would be silly enough to build a mixer without it. Each channel has a comprehensive tone control network, almost always with at least two bands of parametric equalisation. The term 'parametric' refers to the fact that all the parameters of the circuit are adjustable - frequency, bandwidth (Q) and boost/ cut.

Daniel Flickinger introduced the first parametric equaliser in early 1971 (US Patent 3752928 A). His design used opamps to create filter circuits that were not viable with other techniques. Flickinger's patent ("Amplifier system utilizing regenerative and degenerative feedback to shape the frequency response") shows the circuit topology that was used, and it forms the basis of parametric EQ used to this day.

An earlier form of comprehensive tone control was the graphic equaliser - so-called because the slider pots described a 'graph' of the final frequency response. To be useful, a graphic EQ system needs a lot of separate filters. Octave band graphic EQ systems used 10 slide pots, with one for each octave. More expensive units had 20 sliders (1/2 octave) or 30 sliders (1/3 octave). It was common for these to use ferrite-cored inductors prior to the development of integrated opamps and the invention of the 'gyrator' circuit. A gyrator uses an opamp, resistors and a capacitor to simulate an inductor (hence the generic name 'simulated inductor').

It's often been stated that "tone controls are provided so the user can mess up the sound". In many cases this is certainly true, but it has to be considered that the end-user is perfectly entitled to mess up the sound if s/he wants to do so. This article is not about ultimate sound quality, but the various types of equaliser that are available, and how they work.

It's also worth your while to browse the various circuits from the ESP projects list. There are quite a few different types of equaliser described, ranging from simple bass and treble controls through to quasi-parametric designs, graphic equalisers and fixed EQ systems for low frequency response extension for loudspeakers and subwoofers.

Note that all the circuits shown below rely on a low or very low impedance source. This can be an opamp (best), transistor emitter follower (ok) or a valve cathode follower (worst), depending on the other circuitry used. So, although input buffers are not shown they are essential in all cases. This still applies where the input uses an inverting opamp stage, because the insertion loss of the circuit depends on a low source impedance.

The circuits below are not for construction (although you can do so if you wish, but don't expect assistance). Because they are not projects, none has been built as shown, and although all have been simulated no other tests have been done. Likewise, there's been no attempt to optimise the circuits for any particular task, so they may not be found suitable as described. I will respond to queries about projects, but I will not provide assistance to anyone to build any of the circuits shown here.

1 - Fixed Equalisers

The most common fixed EQ circuit is that used for RIAA vinyl phono playback from magnetic pickups. Although there is vast number of different topologies, the end result is pretty much the same. RIAA playback EQ provides bass boost and treble cut to match the disc cutting process. This (by design) cuts the bass response so the grooves aren't so wide as to cut into adjacent grooves, and boosts the treble as a form of pre-emphasis. Upon playback, the treble cut reduces the disc's surface noise sufficiently to produce a fairly quiet end result.

Other common fixed equalisers are or were used with recording tape, FM broadcast, long phone lines used for radio or television distribution and a multitude of other systems. Pre-emphasis (treble boost) and de-emphasis (complementary treble cut) increase the apparent signal to noise ratio (SNR) and these have been used for many years. Pre-emphasis is used in FM broadcasts, and the receivers have a complementary de-emphasis circuit that gives an overall flat response.

Fixed equalisers can also be used to allow a loudspeaker to achieve (or attempt) 'full range' from single loudspeaker drivers. One of the best known is probably the Bose 901, which uses 9 × 100mm (4") drivers and has a 'line level' equaliser that supposedly produces flat response (although it also has some tone control available). Many subwoofers use a fixed equaliser to get as low as possible even in a small enclosure.

Modern systems using DSP (digital signal processing) may also qualify as 'fixed' EQ, because after the setup process is complete there is usually no facility to adjust the relative levels. There's also a movement to apply EQ to 'correct' the speakers for the room, but this is a flawed concept for the most part, other than for frequencies below ~100Hz or so. In a nutshell, you cannot equalise a room, because most of the problems are caused by anomalies in time, and you cannot correct time with amplitude.

Fixed EQ is also used in smartphones, tablets and laptops, usually both for the inbuilt microphone and speakers. The amount and type of EQ depends on the manufacturer, but it's safe to say that it will usually be done using DSP. Some may allow applications to disable the microphone EQ (and compression) for wider frequency and dynamic range. Another form of fixed EQ is a notch filter, and these can be extremely narrow and used to remove an unwanted frequency. An example is the 19kHz notch filter used in FM receivers to suppress the 19kHz pilot tone that's used for stereo broadcasts. Notch filters can also be used to remove 50/60Hz hum from a signal without greatly affecting nearby frequencies.

The primary purpose of this article is to describe user adjustable controls, not fixed EQ systems. Therefore I shall not delve into the realm of fixed equalisers other than in passing.

2 - Tone Controls For Reproduction

The early forms of boost/ cut tone control circuits were passive, and had a significant insertion loss. Because there was no active circuitry in the circuit itself, in order to be able to boost the bass or treble, the overall signal was attenuated. Simple filter circuits allowed the end user to independently set the bass and treble controls to obtain a sound that was pleasing to the listener. Accuracy was never a consideration, and the setting used was purely subjective.

Probably one of the earliest use of equalisers for audio was to try to get decent (and intelligible) sound from early movie soundtracks [ 3 ]. It's not known if there were any equalisers used for radio broadcast, but I'd be surprised if at least some form of (perhaps fixed) filtering wasn't applied to compensate for deficiencies in the transmitter modulators and other parts of the transmission chain. There was definitely a requirement to limit the bandwidth, because AM transmission cannot be allowed to be full frequency range due to the problem of potential adjacent station interference. These don't qualify as tone controls though, because they had fixed frequency response. The same applies to 'equalisers' used to correct phone-line transmissions.

The top-cut style of tone control was standard on most mantel radios and even record players up until the late 1960s. In the valve era, it wasn't possible to include 'proper' tone controls in budget equipment because valves were expensive, and at least one triode was needed to bring the signal back to normal level. Although there were many 'high end' hi-fi systems and construction projects published in Wireless World (UK, now Electronics World), R,TV&H in Australia (Radio, Television & Hobbies) and Practical Electronics (US) and many other magazines, only the more affluent enthusiasts could afford the off-the-shelf equipment that had the latest and greatest tone controls (and other specifications to match).

There was a period where the best equipment available was expected to have tone controls. The Quad 22 preamp was an example, and that had quite sophisticated controls, featuring bass and treble as expected, but also having a switchable low pass filter (5kHz, 7kHz and 10kHz) to help reduce noise from the signal source. At that time (1950s to 1960s and beyond), nearly all preamps had tone controls, and many innovative new topologies were developed to provide more control over how the controls functioned. Some allowed for quite radical amounts of boost and cut. Up to ±20dB wasn't unheard of, but most were limited to a more sensible ±12dB or so.

When graphic equalisers were first introduced to home hi-fi systems they were usually very basic. Some had as few as five bands (2 octave range), and although quite limited gave the home listener plenty of scope to mess up the sound. However, if the end result made the owner happy then that's all that really matters. With most systems today, the inclusion of DSP (digital signal processing) allows the user to select any number of 'effects' that can ruin everything with far greater ability than anything that has come before.

Most simple tone control circuits use the simplest type of filter - resistance/ capacitance (RC) networks that provide a theoretical maximum slope of 6dB/ octave. Those using capacitors and inductors (real or simulated) can achieve far greater slopes, but are configured as band-pass or band-stop (depending on the pot position). Graphic equalisers come in two major formats too, with the most common types providing a variable Q (bandwidth) depending on the amount of boost and cut. The other type is 'constant Q', patented by Ken Gundry of Dolby Laboratories and further developed by Rane. These have a (more or less) constant bandwidth regardless of the amount of boost or cut.

The Langevin Model EQ-251A was the first equaliser to use slide controls, but in this case they were slide switches, not pots as we expect today. It used only passive sections, and each filter had switchable frequencies and used a 15-position slide switch to adjust cut or boost. The first true graphic equaliser was the type 7080 developed by Art Davis's Cinema Engineering. It featured 6 bands with a boost and cut range of 8dB. It used a slide switch to adjust each band in 1 dB steps. Davis's second graphic equaliser was the Altec Lansing Model 9062A EQ. In 1967 Davis developed the first 1/3 octave variable notch filter set, the Altec-Lansing 'Acousta-Voice' system.

3 - Tone Controls For Production

It's important to understand that there is a vast difference between the tone controls that may be used on a hi-fi or mixing console and those used in guitar or other musical instrument amps. In the hi-fi or mixer cases, it is essential that a flat response is available, simply by setting the boost/ cut controls to centre. The circuit then has no effect on the response, so what goes in comes out without change. With musical instrument amps, the situation is very different. The tone controls work in conjunction with the instrument, pickups and the loudspeakers, and the overall effect is to provide a wide range of 'tones' through the speaker that are pleasing to the musician.

For example, a guitar amp is not intended to reproduce sound, it's intended to create (produce) sound. The amplifier and speaker system form part of the instrument - any one without the other is pretty much useless. Try playing a well liked recording through a guitar amp - you will never get it to sound right. Much the same happens if a guitar is played through a hi-fi system. Even if it has tone controls, it will be difficult or impossible to get 'the sound' that a guitarist is used to hearing, and you'll probably end up with blown tweeters to add injury to insult (as it were).

Early guitar amplifiers often had no more than a 'top cut' tone control, but users wanted more. The 'tone stack' as it's generally known now was developed fairly early, but despite much searching I was unable to find out who designed the first version. The guitar amp style tone stack is only capable of providing bass and treble boost (which equates to a midrange cut). The midrange control only lifts the average level across the frequency range, and is deliberately limited so it doesn't render the bass and treble controls inoperative. In most designs, there is no setting that has a flat frequency response - all you can do is vary the amount of bass and treble boost. These circuits are always passive, and have an insertion loss of 20dB or more. Insertion loss simply refers to the amount of signal you get at the output vs. the input, with the controls set to flat or the closest to 'flat' that the circuit can provide.

A few designers over the years have used Baxandall (feedback) tone controls in guitar amps (often as magazine projects), and most qualify as bloody awful at best, unusable at worst. This isn't to say that they can't be used, but in general guitarists will not be at all happy with the end result. To anyone who has designed a guitar amp or two (or three, or ...) this comes as no surprise. Music production and reproduction are very different, and cannot be considered equal in any way. While electric guitar can be especially hard to get right, bass guitar and acoustic guitar with magnetic or piezo pickups can also be very demanding.

4 - Basic Tone Controls

The simplest, most basic and least useful tone control simply provides bass and/or treble cut. These are easily created and were very common in many earlier wireless sets. Bass cut wasn't so common, but nearly all mantel radios from the 1940s onwards featured a 'tone control', which was nothing more than a variable treble cut. By varying a pot, the high frequency response could be rolled off to allow the user to obtain a 'mellow' sound that had a very restricted top-end. Even from an early age, I found that setting the tone control to the position that gave the most treble (such as it was with an AM mantel radio or similar) was far more satisfying than the muffled sound that my parents seemed to prefer.

The general principle is shown below. No boost was possible for bass or treble, simply because early radios and record players barely had enough gain to reach full volume even without any tone control, so reducing the gain to allow boost for separate bass or treble controls wasn't an option. Gain was expensive, because it required another valve stage. The important part here is that if you want to be able to boost bass or treble with a passive network, the entire signal has to be reduced so the filters can be adjusted to provide an apparent boost. Simple bass and treble cut controls are shown below, as these are the most basic of all.

Figure 1 - Bass And Treble 'Cut' Controls

These controls have the minimum possible effect on the rest of the signal, so they could be added without any gain penalty. This meant that an additional valve or transistor wasn't needed, so the cost of including them wasn't great. A couple of potentiometers, knobs, resistors and capacitors was all that was needed. With both controls set for maximum cut, the effect was to provide a signal that was all midrange - no bass, no treble, only the mid frequencies. However, if the two are combined there will be some interaction.

Note that as the controls are adjusted, they can only cut - there is no facility to boost the signal at any frequency. The treble cut control reduces the level by 6dB/octave from a turnover frequency determined by the pot position and the bass cut control does the same. Treble control can also use a variable capacitor, but that was never appropriate because of the physical size of a variable capacitor with enough capacitance to be useful. It can be done easily with a capacitance multiplier, but these were never used in the valve era and remained uncommon until opamps became readily available. With the values shown, the -3dB frequency response with both controls set for maximum cut is from 177Hz to 2kHz. With the pots set for minimum cut the response is essentially flat from 30Hz to 20kHz. The circuit must be followed by a high impedance stage and fed from a low impedance.

If you need to apply boost at any frequency, you need to accept a loss that's slightly greater than the boost allowed or incorporate a gain stage. This can be a valve, transistor, FET or opamp, depending on the era of the design. Early cut/boost tone controls were passive and could introduce a loss of as much as 20dB with the pots centred (flat response). This loss had to be made up by adding a gain stage.

The general scheme seen below is often referred to as a 'James' EQ, so called because it was first published by E.J. James [ 1 ]. You may also see it referred to as a 'passive Baxandall', but that's not correct. The design published by Peter Baxandall is active, and uses feedback to get symmetrical boost and cut. The Baxandall tone control requires an inverting amplifier stage with low output impedance to drive the filter circuits. The James circuit requires a low source impedance and high impedance load, or performance will suffer.

Figure 2 - Passive Bass And Treble Cut/Boost Controls

There are countless variations on this basic circuit. As shown, it's one of the more common arrangements and allows a nominal cut and boost of around +18dB and -20dB (it's not perfectly symmetrical). The bass and treble turnover (±3dB) frequencies are changed by using different capacitor values. Smaller caps work at higher frequencies. The bass section can use one capacitor (in parallel with VR1) or two as shown. The treble section may also use two caps as shown, vs. a single cap in series with the wiper of the treble pot.

There is a slight difference between the circuit variations. Tone control circuits must be driven by a low output impedance (cathode or emitter follower), and there is some interaction between the controls with most passive versions. A true flat position is difficult to achieve with the Figure 2 controls, and a frequency deviation of up to ±2dB is not uncommon. Note that the pots are logarithmic - linear pots do not work, but log tapers are rarely good enough to ensure front panel calibration for flat response. Insertion loss is about 20dB. The following stage must have a high impedance input, and direct coupling to the grid of the following valve (with no additional grid resistor) was not uncommon. A gain of 10 is needed to restore the level with the controls set for a nominally flat response.

Figure 3 - Restricted Range Passive Bass And Treble Controls

The above shows a very simple EQ circuit that I devised a great many years ago for simple stage mixers and 'pre-mixers'. The idea was to provide some control, but not so much that it would get inexperienced users into trouble. The basic scheme is superficially the same as that shown in Figure 2, but the components are the same value for the 'top' and 'bottom' parts of the circuit (compare this with Figure 2). The insertion loss is small (6dB with the controls centred), and the maximum boost is limited to a little under 6dB. There is more cut available, but that only becomes apparent with the control(s) set for minimum bass or treble cut.

Response of the bass pot is shown in green, and treble in red. The pots are linear, and graphs are shown at 25% increments. Unlike the version shown in Figure 2, when the pots are centred the response is completely flat, with almost no deviation at all. There is a small deviation that can be measured, but it's below audibility (about 0.3dB with a 100k load, or 0.03dB if loaded with 1 megohm).

Figure 4 - Restricted Range Passive Control Response

Interestingly, the Figure 3 circuit is almost exactly what you'd expect to see used with an inverting gain stage in a Baxandall control circuit [ 2 ]. The same values used with an inverting gain stage give perfectly symmetrical boost and cut, with a maximum of ±15dB with the values shown. This type of control is shown next, and was very common in home hi-fi systems and mixing consoles. The circuit is seen below, using the exact same component values as shown in Figure 3, but with the addition of an opamp gain stage.

Figure 5 - Baxandall Active Tone Control

This type of circuit is possibly the most popular of all time. Some manufacturers have provided switchable capacitors so the response can be tailored to the user's preferences. There are variations with a midrange control, which is achieved by adding a third pot that has a cap in parallel (like the bass control) and another (smaller) cap in series with the wiper (like the treble control). When a midrange control is included, it's almost always fixed - to make it variable requires switched capacitors.

The generic term for equalisers with the type of response provided by James and Baxandall tone controls is 'shelving EQ', because the bass or treble is boosted by a set amount, but then returns to being almost flat above or below a frequency that's determined by the setting of the control pot. You can see this in Figure 4, the boost and cut level out below 200Hz and 4kHz. Because the Figure 3 circuit is passive and has no feedback, at maximum cut the bass doesn't level out until about 60Hz, and the treble doesn't really level out at all. Once feedback is applied, this changes as shown in Figure 6.

Figure 6 - Baxandall Active Tone Control Response

Colours and pot increments are the same as used for Figure 4. You will notice that boost and cut are now (almost) perfectly symmetrical. Remember that these plots used the exact same tone filters as shown in Figure 3, and the only difference is the addition of feedback.

The full performance and symmetry of Baxandall circuits was difficult to realise with valve circuitry, because getting a very low output impedance from the drive and feedback stages was extremely difficult. As is common with all valve circuits, the tone control networks were high impedance, using 100k or higher for pots, and with other components scaled to suit. It became easier when transistors were used, and was virtually automatic when opamps were used as the source and amplifying devices. Perhaps some of the nostalgia for valve circuitry was the rather 'sloppy' response obtained due to relatively high impedances. This can be restored (why?) by adding resistors in series with opamp outputs.

It's to be expected that some people will insist on passive controls, because they imagine that applying feedback somehow ruins the sound. This is complete nonsense of course, and there seems little point in using a vastly inferior tone control system that has no real flat setting just to avoid the 'evil' of feedback. If this approach is taken, only the Figure 3 circuit is really suitable, because a flat setting is possible and dubious (at best) log pots are not needed.

Figure 7 - Baxandall Active Tone Control With Midrange

In the interests of completeness, the above shows the general arrangement used to add a midrange control to a Baxandall network. The Q is low (about 0.5) and you can't adjust the frequency, but it does add some extra functionality that might be useful for a musical instrument amp. While you may see it added in many circuits on the Net, it's of somewhat dubious value. Because it's not easily adjusted for frequency and due to the low Q, most users are likely to find it doesn't really do what they need.

5 - Graphic Equalisers

While the basic shelving filters described above are fine for controlling bass and treble, to affect the midrange or a troublesome frequency anywhere in the audio band isn't possible. In many cases bass and treble controls don't even work for bass and treble. For example, if you want to get a 'fat' kick drum sound you might add some bass, but you don't want or need to keep boosting all the way down to a few Hertz. Look at Figure 6 - if you have 10dB of boost at 70Hz, you have slightly more than that at 40Hz and it's still there at 20Hz. A peaking filter can be tuned to 70Hz (for example) to give a satisfying 'thump' from the kick drum, but the level returns to normal (towards 0dB gain) as the frequency increases or decreases.

Graphic equalisers have a series of bandpass filters, with each frequency band controlled by a slide-pot. Each frequency can be cut or boosted, and uninformed fiddling can cause problems. There was a brief period where stereo graphic EQ was considered a 'must' for what's probably better known as 'low-end hi-fi' - comparatively cheap systems that made up for the lack of overall quality by including extras that made the buyer believe s/he was getting a good deal.

This general form of equaliser was developed in the early 1970s, and inductors were used as part of the frequency selective networks. Inductors are comparatively large, require many turns of wire and a magnetic core (steel laminations or ferrite). They are expensive to make, and nearby magnetic fields can induce hum into the windings.

Graphic EQ was therefore expensive and quite bulky until the invention of the gyrator (a 'simulated' inductor, using an opamp to invert the action of a capacitor). Although the gyrator was proposed in 1948 (by Bernard Tellegen, a Dutch engineer who also invented the pentode valve), practical realisation wasn't possible until opamps became readily available. Very basic gyrators can be made using only a transistor, but their performance is sub-standard. I don't know of anyone who has tried to make a gyrator using valves because it would not be sensible. The active element of a gyrator is a non-inverting unity gain buffer, which should have high input impedance and low output impedance.

Gyrators allowed designers to create large numbers of 'inductors' very cheaply compared to true inductors, and gyrators are unaffected by magnetic fields so induced hum was no longer a major problem. The general form of a graphic equaliser is shown below, but using inductors for clarity. It doesn't matter if the inductor is 'real' or simulated, it has exactly the same effect. Note that the value of the resistor (R2, R3, etc.) is often the winding resistance of the inductor, and/or an external resistor used to ensure that the series resistance of each tuned circuit is identical. In the following drawing, only the first 5 octave band filters are included. The remainder follow the standard octave frequencies. Industry standard frequencies for the three most common equalisers are ...

31 63 125 250 500 1k0 2k0 4k0 8k0 16k
Octave Band Frequencies - 10 Band

31 44 63 87 125 175 250 350 500 700 1k0 1k4 2k0 2k8 4k0 5k6 8k0 11k 16k 20k
1/2 Octave Band Frequencies - 20 Band

25 31 40 50 63 80 100 125 160 200 250 315 400 500 630 800 1k0 1k2 1k6 2k0 2k5 3k2 4k0 5k0 6k3 8k0 10k 12k 16k 20k
1/3 Octave Band Frequencies - 30 Band

The frequencies shown above are pretty much agreed upon worldwide, and have been adopted by all manufacturers making graphic equalisers. The 1/2 octave and 1/3 octave frequencies are often extended above and below those shown, and may include 20Hz and/or 25Hz, as well as 20kHz. The drawing below shows ideal values rather than those readily available, purely for convenience. The Q of each filter is about 2, extreme accuracy is not really possible and fortunately isn't necessary. The circuit below must be driven from a low impedance. Normally, there would be a unity gain buffer to drive the input. It isn't shown but must be included unless the previous stage is an opamp or other very low impedance source.

Figure 8 - Graphic Equaliser General Scheme, Using Inductors

Without the frequency selective networks (C1, L1, etc.), the pot sliders simply vary the gain of the circuit and unity gain is achieved when the slider(s) are centred. When the pot wiper is close to the input (+ve input of U1), the incoming signal is attenuated (cut), and at the opposite end (shown with a + sign) the opamp has gain (boost). When each pot connects to a tuned circuit, only the frequencies passed by the tuned circuit are affected.

The tuned circuit filters have a minimum impedance at a particular frequency as shown, so the pot affects only those frequencies passed by the filter. A series resonant circuit has a minimum impedance at the resonant frequency, and this forms the basis of most simple graphic equalisers. The scheme shown above gives an equaliser whose actual Q (as opposed to the theoretical value) varies with the slider setting. At low boost or cut settings the bandwidth is much wider than expected.

One thing that is fairly difficult to find explained in simple terms is just how to determine the inductance and capacitance needed for a specific Q. The values depend on the load (series) resistance, which in the above circuit is 470 ohms. The impedance (X) of the cap and inductor must be scaled to the load resistance (RL), and the following formulae apply ...

X = RL × Q
C = 1 / ( 2 × π × X × f )
L = X / ( 2 × π × f )

The Q (which determines the bandwidth) of each filter depends on the number of sliders used (10, 20 or 30). A 1/3 octave graphic EQ needs higher Q filters than a 1 octave band type. Q is defined as the centre frequency divided by the bandwidth, and a 1 octave filter requires a Q of 2. A 1/3 octave EQ system needs filters with a Q of 4.31 (4 is close enough for an equaliser). You may well ask why the Q isn't constant, and the answer is quite simple.

When the pot is near the centre position, the load on the tuned circuit is no longer 470 ohms, it's 470 ohms plus the equivalent resistance of the pot and the feed resistors (2.7k as shown). As the pot position varies, so does the Q, and therefore the bandwidth changes as well. This type of circuit cannot provide a constant loading on the tuned circuit, so cannot provide a constant Q. The effect can be reduced slightly by using lower value pots, but that increases the noise gain of the opamp, so the circuit will become noisy even with a low noise opamp. The opamp inputs are not virtual earth types, and both have a relatively high impedance.

A constant-Q graphic equaliser suitable for subwoofer equalisation is described in Project 75, and this arrangement was first published by Bob Thurmond [ 5 ] and is shown next. Commercial units were pioneered by Rane [ 6 ], but using a different circuit.

Figure 9 - Constant Q Graphic Equaliser (One Section Shown)

It's important to understand how this circuit differs from the previous version. The most obvious difference is that the opamp inputs are both virtual earth (close to zero impedance), and the band pass filters are not RLC types as shown above. You may see a variety of different active bandpass filters used. Typical types are multiple feedback, twin or bridged tee or even state-variable. It is possible to use RLC filters (resistance, inductance, capacitance), and gyrator based filters can be used with some extra circuitry, but the other filter types remain a simpler and better choice.

You can see that the pots control the output from each band-pass filter (BPF), and the multiple outputs are summed along with the input signal at the input to U1 (signal cancellation or cut) or U2 (signal augmentation or boost), depending on the pot position. When the pot is centred, the signal to U1 and U2 is identical, so it cancels and there's no boost or cut for that frequency. The Q remains constant because it's only the output from the appropriate BPF and the load doesn't change.

Figure 10 - Variable Q Vs. Constant Q Response

Above you see the response of two equalisers, one configured as a traditional graphic EQ and the other configured for constant Q. Assuming equal bandwidth for each, both will have the same response at maximum boost or cut, but the situation is quite different at any setting below maximum. The setting for constant Q vs. variable Q is shown for a pot setting of 75% (50% boost). Cut response is the same (but results in a dip of course).

Figure 11 - Gyrator And Band Pass Filter

The general topology of a gyrator and band-pass filter are shown above. The effective inductance of a gyrator is simply the product of the three components (R1, R2 and C1). When the three are multiplied together, the answer is the inductance in Henrys. Equivalent winding resistance is the value of R1. Gyrators are covered in greater detail in the article Active Filters Using Gyrators - Characteristics, and Examples. The multiple feedback bandpass filter is a simple and fairly straightforward design, although calculating the values can be very irksome. They are described in detail in Project 63, and there's even a calculator program available that you can use to work out the component values for you. The multiple feedback filter is not easily tuned, and when variable frequency is needed the choice is between the various bandpass filters covered in the section about parametric equalisers.

While a graphic EQ is certainly a very flexible way to control the frequency response, they need a large number of slide pots and therefore take up a lot of room. This makes their use on mixing consoles (for example) limited to perhaps a couple of graphic EQs for the main or 'FOH' (front of house) outputs. There simply isn't enough space on each channel strip to include one for each channel, and simple bass and treble controls are too limited.

To get the benefits of EQ that can be tailored to the exact needs that doesn't occupy too much space on a channel strip requires a parametric equaliser, discussed below.

6 - Variable Frequency Tone Controls

Simple bass and treble controls can benefit from having adjustable frequencies. It's no longer possible to use the Baxandall topology, so it's done using various other techniques. The easiest is to use the same basic arrangement as used in common graphic equalisers. There have been many schemes used, but most use a variable frequency high and low pass filter in a feedback network. A few (including some that I designed) use an opamp to create a variable capacitance (a capacitance multiplier), and others have used a variety of circuits. It would be silly to try to include them all, so only two variants are shown.

The first is fairly conventional, and there are quite a few references to very similar circuits on the Net. The circuit consists of two inverting gain stages and two unity gain buffers. The latter isolate the boost and cut controls from the frequency networks, and are essential to prevent unwanted interactions. VR1 changes the bass frequency from 200Hz to 740Hz at the ±3dB point. VR2 does the same for the treble, from 460Hz to 1.4kHz, again at the ±3dB frequencies with full boost or cut.

Figure 12 - Variable Frequency Bass & Treble Circuit

The above circuit works well and is not critical, and component values can be changed to increase the frequency range or provide more (or less) boost and cut. As a general purpose tone control, it's far more flexible than the standard Baxandall circuit, but gives almost identical results for any given frequency setting. A better solution uses a variable gyrator for the low frequencies and a variable capacitance multiplier for high frequencies. This has the advantage that the bass control can be switched from shelving to peaking, and additional sections can also be added.

Figure 13 - Variable Frequency Bass & Treble Circuit #2

The gain and boost/cut circuitry is identical to that used for a conventional graphic EQ, and is easily expanded as described in the Project 28 page. As a parametric equaliser it's not wonderful, but it's still surprisingly effective. If you only want variable frequency bass and treble controls it's better than the circuit shown in Figure 12 because you get the option of shelving or peaking for the bass control. As noted above this can be especially useful for percussion (kick drum, toms and kettle drums for example). The circuit uses three unity gain buffers and one gain stage. The input buffer is not needed if the source has a low output impedance, such as from another opamp in the circuit.

In shelving mode, the circuit works almost identically to that shown in Figure 12. The range of each frequency control can be changed by using a higher (or lower) value pot, and the frequencies are changed by replacing C1, C2 and/or C3 with values that provide the desired ranges. For the peaking filter section (C1 in circuit), the ratio of C1 and C2 determines the resonant circuit Q (C2 determines the inductance of the gyrator). Normally there is an optimum ratio (typically around 10:1) for C1 and C2, but because the inductance is variable vis VR3, the optimum ratio can't be maintained.

There is one thing that the Figure 13 circuit does that is not especially desirable, When in peaking mode, the Q changes depending on the setting of VR3. At very low frequencies the Q is higher than at higher frequencies. This variable Q is either a benefit or a curse, depending on what you want to do. With the values shown, the Q ranges from 9.5 to 2.0 (at maximum boost or cut, and at 35Hz and 150Hz respectively). At settings below the maximum cut or boost the Q is reduced. It's normal for this type of equaliser, and if you need a circuit that has consistent Q you need a proper parametric EQ as described next.

7 - Parametric Equalisers

The most flexible EQ that occupies the least space is a parametric equaliser. Provided the bass can be switched from shelving to peaking mode (and many can), you can insert a peak or dip anywhere you like to get the sound you want. Parametric EQ ranges from simple fixed bandwidth types (such as the one shown in Project 28) through to fully variable 'true' parametric equalisers based on state-variable filters. Simple versions like the P28 circuit provide no control over the bandwidth (Q), but are nonetheless very flexible and can perform most 'sound-shaping' EQ tasks very well. Variable Q is needed if you happen to have a requirement to notch out a particular troublesome frequency. High Q (narrow bandwidth) peaks are rarely needed and if used can create problems with the final mix.

It's almost unheard of to use parametric EQ for a home system. These equalisers are not easy to drive, and should only be used by those who understand how they work and what they do. If adjusted incorrectly it's quite possible for an inexperienced user to not just mess up the sound, but it may be possible to kill tweeters if a substantial boost is applied close to the crossover frequency, so the tweeter receives too much energy at its lowest recommended frequency. Home systems aren't just operated by adults, and kids like to experiment! Hi-fi manufacturers assume (not unwisely) that the average user would be confused by all the options provided, and most 'high-end' equipment offers no form of tone control at all.

As with graphic equalisers, a parametric EQ can be configured for variable or constant Q. Each requires a different approach to the circuit. There are countless variations for parametric equalisers, but the best all-round filter network is the state-variable topology. This is a relatively complex circuit, but has the advantage of being easily adjusted both for frequency and Q. Demands on the opamps are fairly modest and comparatively cheap opamps can perform well.

Figure 14 - Wien Bridge Based Parametric EQ

A simpler version uses a Wien bridge as the variable frequency element. These really qualify as 'quasi parametric' EQ, because the Q is fairly low (around 1.3) and can't be changed. However, they are well behaved and easily tuned. A variable frequency stage needs only one opamp in its simplest form, and the tuning network is completely passive. It might seem unlikely that this would be useful, but the Q is actually much greater than a 3-band Baxandall tone control (which only manages a Q of about 0.5), and it can be tuned with a dual-gang pot. This network is not suitable where high levels of boost or cut are needed, as the circuit will oscillate if the gain is too high (set by R6). Without R6 the maximum boost and cut is 9dB and with the values given the maximum is 12dB. The performance can be improved a little by adding a buffer between the pot and the Wien bridge network, but in general the benefit does not outweigh the added expense. There's a lot more info on this topology in Project 150. The Wien bridge network consists of VR2 (A & B), R2, R3 and C1, C2.

Most 'true' parametric equalisers use a state-variable filter (see State-Variable Filters for a detailed analysis). Although comparatively complex, the state variable filter gives independent control of Q and frequency. There are many variations on the scheme, but the end result is fairly similar. In the following drawing, the control section is identical to that shown in Figure 14, and the filter is simply changed from a Wien bridge to a state-variable.

Figure 15 - State-Variable Parametric EQ

VR3 controls the filter Q without affecting the gain, and VR2(A & B) controls the frequency. With the values given, the frequency range is exactly the same as the EQ in Figure 14, because the values that determine the frequency are the same. The Q can be varied between 5.3 down to 0.5 which gives a very wide control range. Note that VR1 (cut/ boost) operates opposite to the way it does with the Wien bridge circuit. As shown, boost and cut are limited to 9.5dB, but this can be extended by adding a resistor from the inverting input of U1 to earth. If a 2.7k resistor is added, boost and cut are increased to 12dB.

Parametric Equalisers come in multiple types, and usually include variable frequency bass and treble controls, along with one, two or sometimes three bands of true parametric. Frequency ranges usually overlap, and care is needed to ensure that boost isn't used with two sections tuned to the same frequency. There is always a chance that the equaliser will clip, or the output at one frequency will be so high as to place horn compression drivers (in particular) at risk of damage.

When very high Q is used, it's generally only needed to cut a troublesome frequency. High Q boost is rarely needed other than for a special effect. Because the parametric EQ is so flexible, it takes some time to get used to using it properly. Most DAW (digital audio workstation) software includes digital parametric EQ, and there are some on-line tutorials [ 7 ] that explain how the EQ should be used. One of the general tenets of parametric EQ is to "cut narrow, boost wide", referring to the Q or bandwidth of the filter(s). A high Q notch can be very useful, but boost should normally be low Q and kept to the minimum whenever possible.

8 - Guitar Amp Tone Stacks

The 'tone stack' as it is commonly known is only suitable for guitar or other musical instrument amps. It's very difficult to know where it came from, but tone stacks are used by most guitar amp manufacturers almost exclusively. The arrangement is quite different from a traditional passive control network, and the control pots are wired in series to form a 'stack' (hence the name). They are very economical, and use the minimum possible number of parts, but the controls are usually highly interactive and there is almost always a significant midrange 'scoop' (essentially a broad notch).

Since electric guitars in particular usually have a quite prominent midrange with little bass or extended treble, the midrange scoop makes up for that by boosting the bass and treble and suppressing the midrange. Varying the bass and treble controls shifts the notch or 'scoop' centre frequency and its depth. Where a 'midrange' control is included, the closest to flat response is obtained with bass and treble at zero, and midrange at maximum. A true flat response is usually impossible though. The controls are used to get a guitar sound that suits the player, and the tone controls (as well as the speaker, cabinet and power amp) are used to create sound. The amp has to be considered as part of the instrument, as most guitarists will choose an amp based on the overall sound they can get from the pairing of guitar and amplifier, and linked to their playing style.

There are very wide differences between tone stacks, not only between different manufacturers but even between different models from the same maker. Most are high impedance and are designed for use with valve stages. For best performance they should be driven from a cathode follower, but in some cases even that is abandoned. While guitarists will think that the tone stack in their favourite amp is a work of art, they are really very basic and usually don't work well with sources other than guitar. From a manufacturing perspective, these are the cheapest possible options for tone control, but it just so happens that the characteristics are pretty close to ideal for the purpose. Only a few designers have strayed, and those who were silly enough to try using Baxandall (active) tone controls have never been well received. An Australian magazine once published a guitar amp using an active tone control, and it didn't go down well with most experienced guitar players.

Figure 16 - Tone Stacks, Fender & Marshall

The two tone stacks shown above are typical only. There are many variations between different models, but all have fairly similar overall characteristics. There is no true flat setting, and the midrange control only reduces the depth of the notch, the frequency of which varies with control settings. The controls are interactive, so changing the treble will change the notch frequency and affects the bass to some degree. The bass control has less interaction with treble and mid, and the mid control is fairly subtle.

Insertion loss with all controls centred is much greater with the Fender style (average about 15dB) than the Marshall (about 8dB), and the Fender circuit has more boost for both bass and treble. The notch (which varies from around 300Hz to 1kHz for both) is deeper in the Fender circuit. There is no doubt that the two circuits will sound quite different, but that doesn't mean that a good guitar sound can't be obtained from the two. Many guitarists have a preference, but that's often because a particular amp brand is preferred. There are many other guitar amps, and they nearly all use variations of the two circuits shown. It would be silly for me to even try to show all the different circuits because there are so many.

Figure 17 - Tone Stack Response, Fender & Marshall

The two response graphs shown above are with the controls set at 50%. Because there's often a mixture of linear and log pots, this doesn't relate directly to any knob setting. The midrange scoop is clearly seen in both traces, and this is one of the main features of tone stacks in general. I don't know of any stack that has eliminated the midrange scoop. Only the frequency and depth change.

These controls are easily modified by changing cap values. There is no design process involved, it's purely a case of trial and error, and ultimately it's all about getting the desired sound. What the controls actually do to the response is secondary to what it sounds like. If it does what the player needs then it's good, if not ...

9 - Frequency 'Isolators'

This type of equaliser is almost only ever used by DJs, and it's quite common in DJ mixers. You will rarely see it elsewhere, but if you were to build a 4-way active system based on Project 125 (a 4-way active crossover) you get this ability free. A frequency isolator is usually simply a 3-way crossover network with its outputs summed to return to a flat response. Project 153 describes a 3-band, 12dB/octave, variable frequency isolator, and if you want to see the full version please refer to the project article. The version shown below has fixed frequencies, and although this may seem quite limiting it's often as much as you are likely to need. The term itself is something of a misnomer, in that you can't really isolate the frequency bands because they have a finite rolloff. You can use 24dB/octave filters (as found in Project 125), but that's generally not necessary to get the effects needed.

To be able to get a flat response without having to bypass the equaliser, the filters must use a Linkwitz-Riley alignment. If Butterworth filters were to be used, there would be +3dB peaks at each crossover frequency (410Hz and 4.1kHz) when the pots are all set the same.

Figure 18 - Typical Frequency Isolator

The circuit is simply a 3-way crossover, with the outputs summed. When all pots are set to the same level, the summed output is flat, and the pots let the user turn the level of any band up or down. As shown the frequencies are 410Hz and 4.1kHz, but they are easily changed by changing cap values. The multiple feedback filter (U2) used in the midrange circuit reduces the opamp count. Because it's an inverting stage it means that a separate inverter isn't needed for the midrange. It also is a nuisance because the caps are not the same as those used in the high pass filter (U1) and changing frequencies is more difficult. The alternative is to use a Sallen-Key filter like all the others, followed by an inverter.

Figure 19 - Frequency Isolator Response

With the circuit shown, the gain is 0dB with the pots all set for 50%, and the summed response is flat to better than 0.1dB. The summed response is shown above with bass and treble at 50% and midrange at zero. This is just an example using fixed frequencies, but of course there are many other possibilities. This type of equaliser is not intended to correct the frequency response, they are used by DJs as an effect.

10 - 'Tilt' Controls

Finally, there's one last tone control arrangement that was popular for perhaps 5 minutes or so, sometime in the 1970s. It was used in at least one Quad preamp as well as a couple of others, but it died out fairly quickly because it's not really very useful. The effect was to literally tilt the frequency response, so if the bass is boosted, the treble is simultaneously reduced and vice versa. I'm not entirely sure why anyone thought this was a good idea, but it's part of tone control history, so is included. There are many possible tweaks that can shift the centre frequency or provide asymmetrical response, but these are generally as useless as the circuit itself.

Figure 20 - 'Tilt' Tone Control

The circuit is straightforward, and uses a frequency selective network wired in reverse phase for high and low frequencies. When one end of the spectrum is boosted, the other end is cut. When the pot is centred, response is flat. The following response graph shows the response at 25% intervals of the pot. Despite not being very useful overall, there are quite a few different versions on the Net. All behave more-or-less equally, but the Quad version was limited to ±3dB unlike most you will see (including the one shown). To reduce the range, resistors are used in series with each end of the pot (VR1).

Figure 21 - 'Tilt' Tone Control Response

The circuit would be more useful (or maybe less useless) if the range was restricted to perhaps 6dB of maximum boost or cut, but the same thing can be done with more conventional tone controls, and that allows bass and treble to be boosted (or cut) by different amounts to balance the overall sound. As noted, only a few manufacturers decided to use this type of EQ, and it was short lived - presumably because the buying public didn't like it. I expect it seemed like a good idea at the time, but it's really a rather pointless waste of parts. As you may have gathered, I don't recommend it.

Conclusions

It's fair to say that with the ready availability of opamps, tone controls with greater flexibility and more usable features became possible than were ever available before. When a modern design is set for flat response, there is virtually no change to the signal at all, other than a truly tiny amount of added noise and distortion which is inevitable with any active circuit. Earlier designs could also be fairly flexible, but at the expense of many components (including inductors), and frequencies that could only be switched rather than continuously variable.

When it comes to wide range, flexible EQ, opamp circuits simply cannot be beaten by any earlier technology, despite any contrary claims you might hear. Using DSP is the next level, but there are still many people who prefer to keep signals in the analogue domain if possible. Controlling a complex filter using a touch-screen may be 'high tech', but it's often very hard to beat the feel of knobs on high quality pots. Rotary encoders can be used with digital systems, but you usually lose the ability to see the settings by looking at the knob pointers.

Analogue circuits have another major benefit - they can be built by anyone who can use Veroboard and a soldering iron, or mount parts on a PCB. This isn't even an option for most digital systems unless the person building the circuit can not only solder surface mount parts, but also knows how to program a DSP. There's another disadvantage to the digital approach, and that's IC continuity. Many modern digital ICs (DSPs, ADCs, DACs, etc.) have a short production life, so if the IC fails after a few years it may be impossible to replace. In contrast, opamps have been with us for many years, and there's no indication that any of the popular devices will disappear. Even if an opamp does become unavailable, you can be sure that a suitable replacement with equal or better performance can be found easily.

Whether you like the idea of EQ or not, it's inevitable that it has been used during the production of the original recording. There may be a very small number of tracks that have been created as direct to tape or hard disk without any processing, but they will be few and far between. If such material is not a genre you even like, then there's no point at all. In general, EQ will hopefully be applied only where necessary, and preferably with as little change as possible. However, many producers will abuse your senses and the recording by manipulating frequency response so that even more compression can be added without turning the music to mush. Regretfully, this seems to be a popular pastime [image].

Phase response wasn't even mentioned in any of the descriptions, because it's extremely variable. All equalisers cause phase shift, and the change of phase is much more rapid with a high Q circuit. We can hear the frequency response variation caused by any equaliser, but the phase shift is not audible. There is any number of people who claim that phase is audible, but the claim belies the fact that most programme material has had at least some equalisation, and therefore has phase that varies from the original either for particular instruments and/or for the complete mix.

References
  1. Simple Tone Control Circuit - E.J. James, Wireless World, February 1949
  2. Negative Feedback Tone Control - P.J. Baxandall, Wireless World, October 1952
  3. Operator Adjustable Equalizers: An Overview - Dennis Bohn, Rane Corp.
  4. Duncan's Amp Pages - Tone Stack Calculator
  5. G.R. Thurmond, "New Devices for Equalization," 52nd Convention of the AES, (Abstracts), vol. 23, p. 827 (Dec. 1975) preprint 1076
  6. Constant-Q Graphic Equalizers - Dennis Bohn, Rane Corp.
  7. How to Use a Parametric Equalizer


ELECTRONIQUE 3D - Le baxandall - Le loudness

.

Vu dans ... http://www.electronique-3d.fr/Le_baxandall.html

Je réalise un Baxandall

Circuit imprimé Baxandall
Baxandall avec LM1805
Cliquer pour agrandir
- Nicolas, je t'ai déjà parlé du correcteur de tonalité Baxandall, si tu ne te souviens pas, tu retournes ICI.
En attendant, je te rappelle quand même qu'un Baxandall dans une chaîne audio, correspond au correcteur de tonalités graves - aigus. Il se compose le plus souvent de 2 potentiomètres, parfois trois.
Il a pour but de corriger :

1- Les déficiences d'une chaîne HI-FI, en particulier au niveau des enceintes. Lorsque celles-ci sont trop petites les graves ont du mal à être restitués comme il le faudrait.
2- L'acoustique de la salle, elle peut perturber le signal musical et il est bon parfois de corriger en amplifiant les graves et les aigus.
3- Le plus souvent, c'est par goût de l'auditeur. (beaucoup aiment bien renforcer les sons graves et aigus).

Je te propose donc le schéma de deux correcteurs de tonalité "Baxandall". Les schémas ne sont pas compliqués, et il existe plusieurs versions d'un tel correcteur de tonalité.
Nota: En cas d'utilisation d'une platine disque C1=220nF
- Comme tu le vois, je reste fidèle au NE5532... Il est très bon et pas cher.

- Le Baxandall est constitué de condensateurs, résistances et de deux potentiomètres (R3 R4 C2 C3 R5 R6 C4 C5 P1 P2). IC1 sert d'adaptateur d'impédance.
- C'est le potentiomètre P1 qui commande les graves. P2 s'occupe lui des aigus. Pour ce qui est du condensateur C6 de 10 picofarads, il sert à stabiliser IC2 et limite les hautes fréquences, il n'est pas obligatoire, mais il vaut mieux le mettre...
- Voici, avec les composants choisis la courbe de réponse du Baxandall.
La courbe rouge correspond à un réglage maximum des potentiomètres et la courbe mauve correspond à un réglage minimum. Au centre (courbe verte) la réponse est plate (potentiomètres réglés à 50%).

Courbes de réponse :
Courbe 1
Courbe réponse Baxandall
- Tu vois Nicolas que les graves et les aigus sont amplifiés (ou atténués) jusqu'à + ou -18 dB ce qui est pas mal. À 1000 Hz le gain est à zéro comme il se doit.
- Mais je pense qu'il vaut mieux limiter les graves inférieures à 20 Hz, car dans le cas où c'est une platine vinyle qui est utilisée, des fréquences très basses voire des infra-sons vont parvenir aux hauts parleurs.

Eh alors ! Tout le monde aime cela !

- Bien sûr... Mais il y a une limite...
Je t'explique, maintenant avec le progrès la musique est numérisée sur des CD audio (il n'y a plus de bruit de fond lors de la lecture, comme au temps des platines vinyle). Les disques vinyle existent toujours et ils sont écoutés encore par beaucoup, donc il faut penser à eux.
- Avec les platines disques, il y à plusieurs bruits parasites.
- Les craquements issus de l'usure du disque vinyle et à l'encrassement des sillons.
- Le bruit basse fréquence (le Rumble) dû à la mécanique de la platine elle même. C'est ce dernier qu'il faut atténuer.
- La fréquence de ce bruit se situe entre 5 et 25 Hz et les Hauts Parleurs graves n'apprécient pas ce genre de fréquences, surtout à haut niveau d'amplification.. D'ailleurs sur les chaînes Hi-fi, il existait des filtres anti-Rumble.
- Les courbes (courbes 1) représentées au-dessus correspondent avec un condensateur C1 de 1µ Farad. Ceux qui n'ont pas de platine vinyle peuvent laisser le condo en place, autrement, il vaut mieux le remplacer par un condo de 220 nF. Il atténuera les basses fréquences, ce que tu vois nettement sur les courbes 2.
Courbes 2 - Courbes des graves avec un condensateur (C1) de 220nF
Grave du Baxandall
- La courbe en rouge, correspond avec le potentiomètre des graves réglé à 100%, la courbe verte, le potentiomètre réglé à 50% (position médiane). En position médiane on voit l'atténuation des graves -6 dB à 10 Hz. Compares avec la courbe des graves du haut.

Le circuit imprimé :
Circuit imprimé Baxandall
Le typon
Cliquer pour agrandir
Ce n'est pas possible de le faire sans strap ce circuit ?

Si bien sur... Je les place de façon à simplifier le travail du routeur, ainsi cela évite des pistes en serpentin. Cela évite également de faire des circuits imprimés doubles faces plus difficiles à réaliser.

L'alimentation peut aller de + - 12 à 15 Volts (symétrique).

Le Loudness: (correction physiologique).
- Sais-tu Nicolas, que ton oreille n'entend qu'une infime partie du spectre sonore. En principe l'être humain entend les fréquences qui vont de 20Hz à 20 Khz environ. J'ai bien dit en principe, car cela dépend surtout de l'age. Toi à ton âge il y a de grandes chances pour que tu puisses discerner tout le spectre sonore (20Hz à 20Khz). Mais cela va diminuer à partir de 30 ans environs, au-delà de cet âge, tu entendras de moins en moins les sons aigus.
- Mais ce n'est pas tout, malgré l'excellente oreille dû à ton âge, tu ne perçois pas les sons de façon identique, la sensibilité de ton oreille varie selon la fréquence. L'oreille est plus sensible aux fréquences médium et aigues. Les sons graves eux, sont quelque peu oubliés.

- Voici les courbes isosoniques représentant la sensibilité de l'oreille en fonction de la fréquence et du niveau sonore.

Les courbes isosoniques :

- Nicolas, si tu entendais les sons au même niveau sonore quelle que soit la fréquence, les lignes seraient des droites. Tu vois bien que ce n'est pas le cas et les fréquences graves sont beaucoup atténuées par rapport aux fréquences médium (500Hz à 5Khz).
En prenant comme référence la fréquence de 1Khz et un nivaux constant de 10 dB, tu entendrais les aigus (10Khz) plus fort de 10dB environ et le 20Hz serait lui atténué de 70 dB. Si maintenant, on augmente le niveau sonore à 100 dB, les graves ne sont plus atténués que de 30 dB. Donc plus le niveau sonore augmente, plus la perception auditive devient linéaire.

- Quel rapport avec le Loudness !

- Et bien le Loudness permet de linéariser la perception auditive en amplifiant les graves tout en tenant compte du niveau sonore. Il sera donc très actif à un bas niveau sonore et à peu près inactif à haut niveau.

- Si je comprends bien les composants du loudness seront câblés sur le potentiomètre du volume de la chaîne Hifi.

- Bien vu Nicolas, c'est exactement cela.
Quand il y a un loudness dans une chaîne Hifi, le potentiomètre est plus complexe par rapport à un normal, il lui faut une prise intermédiaire. Il y a donc 4 extrémités sur celui-ci. Vu que ce genre de potentiomètre est difficile à trouver dans le commerce par le particulier, le loudness fabriqué par celui-ci n'est qu'une approche d'un vrai Loudness, car il ne tient pas compte de la puissance sonore.
Pour revenir au LM 1035, celui-ci à un vrai loudness, de plus il est commandé par un simple potentiomètre linéaire. Donc un plus pour ce circuit intégré.

- Voilà Nicolas pour ce qui est du correcteur de tonalité dit "Baxandall"...
- Voici le montage réalisé sur plaque d'essai par un lecteur (Nicolas Peugnet). Message email...

"Je voulais aussi vous dire merci pour le correcteur baxandall mis à disposition que j'ai réussi à réaliser, mais avec les moyens du bord (cf. les photos et pj)
(je n'ai pas fait assez attention : j'ai mis le potentiomètre des graves à droite et celui de aigus à gauche... Et en plus le fonctionnement des aigus est inversé !)
Mais c'est pas grave, il marche bien et je suis très content."

On remarque le travail très soigné... Bravo


Correcteur Baxandall

Vu dans ... http://www.est-usmba.ac.ma/benbrahim/MI1/circuits-elec/TD/EXOS/BAXAN/BAXAN.HTM

Correcteur Baxandall

But de l'exercice

On se propose d'étudier un correcteur de type baxandall : ce correcteur correspond aux commandesgraves/aigus des amplificateurs HIFI, et permet d'atténuer etd'amplifier les graves et les aigus séparément autourd'une fréquence centrale d'environ 1kHz.

Méthodologie

Nous allons faire cette étude à l'aide de la méthode dessystèmes bouclés. Nous allons d'abord identifierles blocs de ce système, puis les réduire àl'aide du théorème de thévenin et du théorème de superposition.

A partir des éléments fournis, les personnesdésireuses de faire le calcul à la main pourront développer les expressions sans problèmes(c'est juste un peu long !). Ici, nous allons utiliser unlogiciel de calcul vectoriel (MathPad, pour Macintosh, mais on peuttransposer à d'autres logiciels pour PC, tels Euler -licenseGNU- ou encore Matlab -pour les riches).

Schéma global

Ce schéma est tiré du livre de Raymond Brault Basse fréquence, Haute fidélité .

Identification des blocs

Le schéma générique est le suivant :

On se reportera au cours sur les AOP, notamment au chapitretraitant de l' ampliinverseur par la méthode des schémas-blocs :la méthodologie est la même.

Pour déterminer le bloc , ilfaut mettre (virtuellement) la sortie du montage à la masse,et considérer le quadripôle compris entre l'entrée dumontage et l'entrée inverseuse de l'ampli. Normalement, attaque l'entrée + de l'ampli : on l'affectera d'un signe -.On obtient le schéma suivant :

Le potentiomètre P1 a étéséparé en deux parties :x1P1, qui est la partie en parallèleavec C1, et (1-x1)P1, qui est laportion en parallèle avec C2. La somme des deux estnaturellement égale à P1. Idem pourP2, x2P2 étant la partiesituée du côté de C3.

La branche du haut est celle qui était reliéeà la sortie, qu'on a mise à la masse.

Le bloc de retour B est obtenu de la mêmemanière : on met l'entrée à la masse, etc'est la quadripôle compris entre la sortie et l'entréeinverseuse du montage :

On remarque que vu la grande symétrie du montage complet, [image] et B sont très similaires.

Le bloc A est tout simplement l'amplificateur opérationnel.Le logiciel de calcul nous permettra de rentrer sa fonction detransfert réelle sans difficultés ; pour le calculà la main, on pourra se contenter de prendre une valeur fixeégale à l'infini, de telle manière que lafonction de transfert globale du montage soit simplement :

Calcul des blocs

Comment aborder ces blocs ?

On peut noter la symétrie de ces montages ; de plus,on s'aperçoit qu'on a deux ponts diviseursd'impédances suivis d'une résistance sériequi attaquent le même point de sortie : on pourraréduire ces ponts par le théorème de thévenin, etensuite utiliser le théorème de superposition.

Pour [image], on obtient :

avec les expressions suivantes :

Ce schéma peut se mettre sous la forme :

avec les valeurs suivantes :

Si on applique le théorème de superposition, onobtient :

est le rapport V- /Ve : onen déduit facilement sa valeur :

Pour B, on a rigoureusement la même chose :

qu'on peut mettre sous la forme :

avec :

Si on applique le théorème de superposition, onobtient :

B est le rapport V-/Vs : on endéduit facilement sa valeur :

Application numérique

Voilà ! Pour rentrer tout ceci dans le logiciel, on vaprocéder rigoureusement comme ci-dessus. A la main, çasera plus difficile... Il faut en effet déveloper toutes leséquations pour ensuite les réduire !

Voilà à priori une excellente raison pour apprendreà se servir d'un logiciel de calcul vectoriel : çasera à peine plus long !!!

Téléchargez le programme( visualisez-le dans lenavigateur), il est documenté et les variables ont lemême nom que celles citées ci-dessus.

Notez que vous ne pourrez pas avoir les faisceaux de courbes commereprésenté ci-dessous : j'ai fait une autre version duprogramme, avec des ruses (nécessaires) qui rendent totalementillisible l'ensemble...


Vu dans ... https://www.sciencedirect.com/topics/engineering/baxandall

Learn more about Baxandall

Computer-Aided Design of Switchmode Power Amplifiers

Andrei Grebennikov, ... Marc J. Franco, in Switchmode RF and Microwave Power Amplifiers (Second Edition) , 2012

12.1.3 Class-D versus Class-DE

P. J. Baxandall published the first description of a Class-D circuit, in a paper discussing voltage-switching and current-switching self-excited oscillators [3] . Later publications by other authors discussed the use of the circuit in tuned and untuned amplifiers. In those early publications, the transistor switches were operated with ‘on’ duty ratio of 50%, resulting in ‘hard turn-on switching’ of the transistors: a turning-on upper transistor ( S 1 in Fig. 12.1( a ) ) would charge the switching-node capacitance from ground up to the positive-supply rail, and a turning-on lower transistor ( S 2 in Fig. 12.1( a ) ) would discharge that capacitance from the positive-rail voltage down to ground. The switching-node capacitance is the output capacitances of the two transistors, plus circuit wiring capacitance. The charging and discharging power dissipations resulting from hard-switching were ( CV 2 f )/2 at each turn-on transition (twice per cycle of the switching frequency), where C is the node capacitance, f is the switching frequency, and V is the dc supply voltage (labeled ‘2V cc’ in Figs. 2.6 and 2.7 Fig. 2.6 Fig. 2.7 , and ‘Vcc’ in Fig. 12.1( a ) ). When the circuit was being used at audio frequencies, that power dissipation was not a problem, but as users applied the technique at frequencies higher than a few-hundred kHz, the capacitor-discharge power dissipation became objectionable.

SA Zhukov and VB Kozyrev published a technique for eliminating the power dissipation associated with charging and discharging the node capacitance [4] . The duty ratio of each transistor switch is reduced from 50% to a lower value, leaving a “conduction gap” during which both switches are “off”, as shown in Fig. 12.3 . During that conduction gap, the current in the inductor of the load network can charge the node capacitance up to the positive rail, and discharge that capacitance down to ground. They suggested choosing the circuit parameters to yield a switch-voltage waveform that has zero voltage and zero-voltage slope, at the time the switch will be turned “on”. Those conditions are the same as in the nominal waveform of a Class-E amplifier described in Chapter 5 . Because the circuit operates like Class-D, modified to have turn-on transitions like Class-E, later authors referred to that variant of Class-D as “Class-DE”. DC Hamill updated this publication and made it easily available to the English-speaking part of the world [5] .

Sign in to download full-size image

Figure 12.3 . Switch timing for a Class-DE.

If the load-network inductance value is intentionally made larger than the value needed for resonance with the network capacitance at the switching frequency, zero-voltage turn-on switching can be achieved with a larger switch duty ratio (narrower conduction gap) than would be needed if the inductance resonated with the capacitance at the switching frequency. That increases the output power available at a given level of peak current in the transistor, or it decreases the peak current needed for a specified output power. A unique feature of the HB-PLUS program is the ability to automatically adjust the values of the circuit elements (capacitors, inductors, and resistors) and circuit parameters (switching frequency and switch conduction duty ratio) to achieve optimum performance. The meaning of “optimum” is defined by an objective function which comprises a series of terms, each of which pertains to one aspect of circuit performance. For each performance parameter of interest, a target value and a handicap (tradeoff) value are entered. The target value is the value which is required to achieve representing, for example, the number of watts of output power. The handicap value represents the relative number of units of that performance parameter that corresponds in importance to the specified handicap values of each of the other performance parameters. For example, if the handicap for efficiency is 2.0 and the handicap for output power is 5.0, the program will understand that an increase of efficiency of 2.0 per cent points has the same importance as an increase of output power of 5.0 W. A handicap value of zero instructs the program to ignore that parameter in computing the objective function.

Read full chapter

The Power Amplifier

Morgan Jones, in Valve Amplifiers (Fourth Edition) , 2012

Global Negative Feedback

We saw in Chapter 3 that Baxandall ’s analysis of feedback showed that provided open-loop distortion is <1% and dominated by second harmonic, any amount of negative feedback from 0 dB upwards proportionately reduces the amplitude of all harmonics and self-generation of higher harmonics is negligible. On test, the 6S4A push–pull output stage produced 0.6% THD just below grid current, dominated by second harmonic, so this amplifier is an ideal candidate for global negative feedback. In the Bulwer-Lytton amplifier, global feedback would have been undesirable because it would have reduced the output resistance required by the Arpeggio loudspeaker, but a more forceful version employing sixteen 6S4As per channel (BL) (2) to give 16 W could drive a more conventional loudspeaker and 20 dB of negative feedback would reduce its maximum distortion to 0.06% – still dominated by second harmonic.

Read full chapter

Let's Stick Together – Recording consoles

Richard Brice, in Music Engineering (Second Edition) , 2001

Equalisers and tone-controls

At the very least, a modern recording console provides a basic tone-control function on each channel input, like that shown in Figure 12.17 . This circuit is a version of the classic circuit due to Baxandall . But this type of circuit only provides fairly crude adjustment of bass and treble ranges, as illustrated in Figure 12.12 . This type of response (for fairly obvious reasons) is often termed a ‘shelving’ equaliser. So, the Baxandall shelving EQ is invariably appended with a mid-frequency equaliser which is tuneable over a range of frequencies; thereby enabling the sound engineer to adjust the middle band of frequencies in relation to the whole spectrum (see Figure 12.12 also). A signal manipulation of this sort requires a tuned circuit which is combined within an amplifier stage which may be adjusted over a very wide range of attenuation and gain (perhaps as much as ±20 dB). How such a circuit is derived is illustrated in Figure 12.18 .

Sign in to download full-size image

Figure 12.17 . Simple tone control circuit

Sign in to download full-size image

Figure 12.18d . Older, passive equaliser circuit

Imagine Z1 is a small resistance. When the slider of VR1 is at position A, the input is heavily attenuated and the lower feedback limb of the op-amp is at its greatest value (i.e. the gain of the stage is low). Now imagine moving the slider of VR1 position B. The situation is reversed; the input is much less attenuated and the gain of the amplifier stage is high. This circuit therefore acts as a gain control because point A is arranged to be at the extreme anti-clockwise position of the control. As a tone control this is obviously useless. But, in the second part of Figure 12.18 (b), Z1 is replaced with a tuneable circuit, formed by a variable inductor and a capacitor. This tuned circuit has a high impedance – and therefore little effect – except at its resonant frequency; whereupon it acquires a very low dynamic impedance. With the appropriate choice of inductor and capacitor values, the mid-frequency equaliser can be made to operate over the central frequency range. The action of VR1 is to introduce a bell-shape EQ response (as illustrated in Figure 12.12 ) which may be used to attenuate or enhance a particular range of frequencies; as determined by the setting of the variable inductor.

Read full chapter

Voltage amplifiers and controls

John Linsley Hood, in Audio Electronics (Second Edition) , 1998

STANDARD TONE CONTROL SYSTEMS

These are either of the passive type, of which a typical circuit layout is shown in Fig. 4.41 , or are constructed as part of the negative feedback loop around a gain block, using the general design due to Baxandall . A typical circuit layout for this kind of design is shown in Fig. 4.42 .

Sign in to download full-size image

Fig. 4.41 . Circuit layout of passive tone control.

Sign in to download full-size image

Fig. 4.42 . Negative feedback type tone control circuit.

It is claimed that the passive layout has an advantage in quality over the active (feedback network) type of control, in that the passive network merely contains resistors and capacitors, and is therefore free from any possibility of introduced distortion, whereas the ‘active’ network requires an internal gain block, which is not automatically above suspicion.

In reality, however, any passive network must introduce an attenuation, in its flat response form, which is equal to the degree of boost sought at the maximum ‘lift’ position, and some external gain block must therefore be added to compensate for this gain loss.

This added gain block is just as prone to introduce distortion as that in an active network, with the added disadvantage that it must provide a gain equal to that of the flat-response network attenuation, whereas the active system gain block will typically have a gain of unity in the flat response mode, with a consequently lower distortion level.

As a final point, it should be remembered that any treble lift circuit will cause an increase in harmonic distortion, simply because it increases the gain at the frequencies associated with harmonics, in comparison with that at the frequency of the fundamental.

The verdict of the amplifier designers appears to be substantially in favour of the Baxandall system, in that this is the layout most commonly employed.

Both of these tone control systems – indeed this is true of all such circuitry –rely for their operation on the fact that the AC impedance of a capacitor will depend on the applied frequency, as defined by the equation:

Z c = 1 / 2 π f C ,

or more accurately,

Z c = 1 / 2 jπ f C ,

where j is the square root of –1.

Commonly, in circuit calculations, the 2 πf group of terms are lumped together and represented by the Greek symbol ω.

The purpose of the j term, which appears as a ‘quadrature’ element in the algebraic manipulations, is to permit the circuit calculations to take account of the 90° phase shift introduced by the capacitative element. (The same is also true of inductors within such a circuit, except that the phase shift will be in the opposite sense.) This is important in most circuits of this type.

The effect of the change in impedance of the capacitor on the output signal voltage from a simple RC network, of the kind shown in Figs 4.43 (a) and 4.44 (a) ,is shown in Figs 4.43 (b) and 4.44 (b). If a further resistor, R2, is added to the networks the result is modified in the manner shown in Figs 4.45 and 4.46 . This type of structure, elaborated by the use of variable resistors to control the amount of lift or fall of output as a function of frequency, is the basis of the passive tone control circuitry of Fig. 4.41 .

Sign in to download full-size image

Fig. 4.43 . Layout and frequency response of simple bass-cut circuit (high-pass).

Sign in to download full-size image

Fig. 4.44 . Layout and frequency response of simple treble-cut circuit (low-pass).

Sign in to download full-size image

Fig. 4.45 . Modified bass-cut (high-pass) RC circuit.

Sign in to download full-size image

Fig. 4.46 . Modified treble-cut (low-pass) RC circuit.

If such networks are connected across an inverting gain block, as shown in Figs 4.47 (a) and 4.48 (a), the resultant frequency response will be shown in Figs 4.47 (b) and 4.48 (b), since the gain of such a negative feedback configuration will be

Sign in to download full-size image

Fig. 4.47 . Active RC treble-lift or bass-cut circuit

Sign in to download full-size image

Fig. 4.48 . Active RC treble-cut or bass-lift circuit.

Gain = Z a / Z b

assuming that the open-loop gain of the gain block is sufficiently high. This is the design basis of the Baxandall type of tone control, and a flat frequency response results when the impedance of the input and output limbs of such a feedback arrangement remains in equality as the frequency is varied.

Read full chapter

Power output stages

John Linsley Hood, in Audio Electronics (Second Edition) , 1998

IMPROVED TRANSISTOR AMPLIFIER DESIGNS

The two major developments which occurred in transistor output circuit technology, which allowed the design of transistor power amplifiers which had a low inherent level of crossover distortion. were the introduction in the mid 1960s of fully complementary (NPN and PNP) output power transistors by Motorola Semiconductors Inc, and the invention by IM Shaw ( Wireless World , June 1969), subsequently refined by P. J. Baxandall ( Wireless World , September 1969) of a simple circuit modification to the basic quasi-complementary output push–pull pair to increase its symmetry.

These layouts are shown in Figs 5.6 (a) and (b). The modified version shown in Fig. 5.6 (c) is that used by the author in his Hi-Fi News 75 W power amplifier design, for which the complete circuit is given in Fig. 5.7 .

Sign in to download full-size image

Fig. 5.6 . Improved push–pull transistor output stages.

Sign in to download full-size image

Fig. 5.7 . JLH Hi-Fi News 75 W audio amplifier.

In many ways the Shaw/Baxandall quasi-complementary output transistor circuit is preferable to the use of fully complementary output transistors, since, to quote J. Vereker of Naim Audio , ‘NPN and PNP power transistors are only really as equivalent as a man and a woman of the same weight and height’ – the problem being that the different distribution of the N- and P- doped layers leads to significant differences in the HF performance of the devices. Thus, although the circuit may have a good symmetry at low frequencies, it becomes progressively less symmetrical with increasing operating frequency

With modern transistor types, having a higher current gain transition frequency (that frequency at which the current gain decreases to unity), the HF symmetry of fully complementary output stages is improved, but it is still less good than desired, so the relative frequency/phase characteristics of each half of the driver circuit may need to be adjusted to obtain optimum performance.

Read full chapter

Preamplifiers and input signals

John Linsley Hood, in Audio Electronics (Second Edition) , 1998

INPUT CIRCUITRY

Most of the inputs to the pre-amplifier will merely require appropriate amplification and impedance transformation to match the signal and impedance levels of the source to those required at the input of the power amplifier. However, the necessary equalisation of the input frequency response from a moving magnet, moving coil or variable reluctance pickup cartridge, when replaying an RIAA pre-emphasised vinyl disc, requires special frequency shaping networks.

Various circuit layouts have been employed in the preamplifier to generate the required ‘RIAA’ replay curve for velocity sensitive pick-up transducers, and these are shown in Fig. 3.4 . Of these circuits, the two simplest are the ‘passive’ equalisation networks shown in (a) and (b), though for accuracy in frequency response they require that the source impedance is very low, and that the load impedance is very high in relation to R 1.

Sign in to download full-size image
Sign in to download full-size image

Fig. 3.4 . Circuit layouts which will generate the type of frequency response required for RIAA input equalization.

The required component values for these networks have been derived by Livy (Livy, W.H., Wireless World , Jan. 1957, p. 29) in terms of RC time constants, and set out in a more easily applicable form by Baxandall (P. J. Baxandall, Radio, TV and Audio Reference Book , S.W. Amos [ed.], Newnes-Butterworth Ltd., Ch. 14), in his analysis of the various possible equalisation circuit arrangements.

From the equations quoted, the component values required for use in the circuits of Figs 3.4 (a) and (c), would be:

R 1 / R 2 = 6.818 C 1 . R 1 = 2187 μs and C 2 . R 2 = 109 μs

For the circuit layouts shown in Figs 3.4 (b) and (d), the component values can be derived from the relationships:

R 1 / R 2 = 12.38 C 1 . R 1 = 2937 μs and C 2 . R 2 = 81.1 μs

The circuit arrangements shown in Figs 3.4 (c) and (d), use ‘shunt’ type negative feedback (i.e., that type in which the negative feedback signal is applied to the amplifier in parallel with the input signal) connected around an internal gain block.

These layouts do not suffer from the same limitations in respect of source or load as the simple passive equalisation systems of (a) and (b). However, they do have the practical snag that the value of R in will be determined by the required p.u. input load resistor (usually 47k. for a typical moving magnet or variable reluctance type of PU cartridge), and this sets an input ‘resistor noise’ threshold which is higher than desirable, as well as requiring inconveniently high values for R 1 and R 2.

For these reasons, the circuit arrangements shown in Figs 3.4 (e) and (f), are much more commonly found in commercial audio circuitry. In these layouts, the frequency response shaping components are contained within a ‘series’ type feedback network (i.e., one in which the negative feedback signal is connected to the amplifier in series with the input signal), which means that the input circuit impedance seen by the amplifier is essentially that of the pick-up coil alone, and allows a lower mid-range ‘thermal noise’ background level.

The snag, in this case, is that at very high frequencies, where the impedance of the frequency-shaping feedback network is small in relation to R FB , the circuit gain approaches unity, whereas both the RIAA specification and the accurate reproduction of transient waveforms require that the gain should asymptote to zero at higher audio frequencies

This error in the shape of the upper half of the response curve can be remedied by the addition of a further CR network, C 3/ R 3, on the output of the equalisation circuit, as shown in Figs 3.4 (e) and (f). This amendment is sometimes found in the circuit designs used by the more perfectionist of the audio amplifier manufacturers.

Other approaches to the problem of combining low input noise levels with accurate replay equalisation are to divide the equalisation circuit into two parts, in which the first part, which can be based on a low noise series feedback layout, is only required to shape the 20 Hz–1 kHz section of the response curve. This can then be followed by either a simple passive RC roll-off network, as shown in Fig. 3.4 (g), or by some other circuit arrangement having a similar effect – such as that based on the use of shunt feedback connected around an inverting amplifier stage, as shown in Fig. 3.4 (h) – to generate that part of the response curve lying between 1 kHz and 20 kHz.

A further arrangement, which has attracted the interest of some Japanese circuit designers – as used, for example, in the Rotel RC-870BX preamp., of which the RIAA equalising circuit is shown in a simplified form in Fig. 3.4 (j) – simply employs one of the recently developed very low noise IC op. amps as a flat frequency response input buffer stage. This is used to amplify the input signal to a level at which circuit noise introduced by succeeding stages will only be a minor problem, and also to convert the PU input impedance level to a value at which a straightforward shunt feedback equalising circuit can be used, with resistor values chosen to minimise any thermal noise background, rather than dictated by the PU load requirements.

The use of ‘application specific’ audio ICs, to reduce the cost and component count of RIAA stages and other circuit functions, has become much less popular among the designers of higher quality audio equipment because of the tendency of the semiconductor manufacturers to discontinue the supply of such specialised ICs when the economic basis of their sales becomes unsatisfactory, or to replace these devices by other, notionally equivalent, ICs which are not necessarily either pin or circuit function compatible.

There is now, however, a degree of unanimity among the suppliers of ICs as to the pin layout and operating conditions of the single and dual op. amp. designs, commonly packaged in 8-pin dual-in-line forms. These are typified by the Texas Instruments TL071 and TL072 ICs, or their more recent equivalents, such as the TL051 and TL052 devices – so there is a growing tendency for circuit designers to base their circuits on the use of ICs of this type, and it is assumed that devices of this kind would be used in the circuits shown in Fig. 3.4 .

An incidental advantage of the choice of this style of IC is that commercial rivalry between semiconductor manufacturers leads to continuous improvements in the specification of these devices. Since these nearly always offer plug-in physical and electrical interchangeability, the performance of existing equipment can easily be up-graded, either on the production line or by the service department, by the replacement of existing op. amp. ICs with those of a more recent vintage, which is an advantage to both manufacturer and user.


Vu dans ... http://sound-au.com/dwopa2.htm

Pure Audio

The next set of circuits are pure audio, and include tone controls, equalisers and filters. Note that just because a circuit is described as 'audio', this does not mean that it can only be used for things we listen to. The audio range simply means that the circuits are designed to operate from 20Hz or less, up to 20kHz or more (but below 100kHz). DC isn't 'audio', but it is considered to be within the audio range for instrumentation or process control (industrial). A vast number of industrial controllers operate within the ;audio' band.

When we speak of audio (that we listen to), the commonly accepted range is from 20Hz to 20kHz, and at some point someone decided that the centre frequency is 1kHz. If we look at the audible range with 1kHz as the key frequency, we get something along the lines of the following...

31.25 62.5 125 250 500 1 k 2 k 4 k 8 k 16 k
Octave Frequencies Based On 1kHz

That doesn't look even remotely centred to me. I have never known why 1kHz was chosen, since if you look at the octaves actually covered by the '20-20k' audio range we have a sequence more like this...

20 40 80 160 320 640 1.28 k 2.56 k 5.12 k 10.24 k 20.48 k
Octave Frequencies From 20 to 20k (Hertz)

This is a total of 10 octaves, and the centre frequency must actually be 640Hz, and indeed this is much closer to reality than 1kHz. If we were to divide the musical spectrum based on energy content, the centre frequency is about an octave lower, or 320Hz (approximately - it depends to a large degree on the style of music).

I am not going to break with tradition (at least up to a point), and note that this has nothing to do with the reference frequency (1kHz) as used for calibrating sound level meters and/or other test instruments. I do suggest that the 640Hz frequency is the 'real' mid frequency that should be applied to tone controls, and not 1kHz as is so commonly found in published circuits. In reality it makes little difference either way. The use of 1kHz as the 'centre frequency' has become so entrenched that no-one will be able to change it. Indeed, the octave frequencies shown based on 1kHz are set in legislation for octave band sound level measurements.

The limitations of opamps in audio circuits must be fully understood. It's informative to look at the compensation curves typical of standard and high quality opamps, and examine the alternatives for very wide bandwidth. These graphs are available in almost all opamp datasheets. Maximum open loop gain (i.e. before feedback is applied) is only available at low frequencies - typically up to 10-100Hz, rolling off at 6dB/ octave as frequency in increased. This means that less feedback is available at 20kHz than at 20Hz. It's usually not a problem unless you expect a lot of gain and a wide bandwidth.

6.1 - Suggested Resistor Values

Based on some of the questions I've seen in forum sites (amongst others), this seems to cause people far more problems than it should. Being able to select suitable values is largely something learned from experience, but there are a few simple guidelines. Resistors used in the feedback network must (by definition) impose a load on the opamp's output stage. Therefore, it would not be sensible to design a simple opamp gain circuit using a 100 ohm feedback resistor, because that will (attempt to) draw up to ±135mA from the output, should the output voltage ever manage to reach ±13.5V (hint - it won't). This is clearly far more current than most opamps can supply.

As a general rule, the feedback network should draw around 1/10th of the available output current. Most opamps will be linear with up to ±20mA output, so the feedback current should be no more than 2mA. If we assume the use of ±15V supplies, the opamp's output will reach around ±13.5V - some more, others less. 13.5V at 2mA is 6.75k, so a resistance of no less (and preferably a little more) is indicated. I generally aim for a value between 10k and 100k, with the lower value preferred as it contributes less noise. It's not always possible to use low values of course, because some circuit topologies demand values that are higher than we might like.

Likewise, very high values cause problems too, and not only for their noise contribution. While a 10Meg feedback resistor may meet other requirements, it will cause serious offset problems with any opamp using BJT (bipolar junction transistors) at the input stage. For example, an NE5532 may draw up to 800nA (0.8µA) of input current. If we apply Ohm's law, that means the voltage across the 10Meg feedback resistor could be up to 8V across the resistor. This is clearly unacceptable.

The above also apply to input resistances (i.e. from the non-inverting input to ground). Never attempt to 'match' the input impedance of a circuit to the output impedance of the preceding stage. For example, if your CD player has an output impedance of 100 ohms, your input impedance should be at least ten times that value (i.e. 1k), and preferably close to one hundred time the output impedance (10k). Impedance matching is important for RF (radio frequency) circuits, where the cable is a transmission line. This never happens in audio, with the one exception being old land-line telephones. This is a complex topic, and is irrelevant here.

Where very high impedances are called for, you should use a FET input opamp. A TL071 has a worst case input current of 200pA, so a 10Meg resistor will only have 2mV across it. The additional noise (both from the opamp and the feedback resistance) is unavoidable, and is the price we must pay for very high impedances.

In all cases, the selection of feedback and input resistors depends on the application. There is no 'one size fits all' answer, and the ability to just come up with a suitable value without maths or even simulations is something that comes with experience. It's often assumed (by the uninitiated at least) that if an opamp has an output impedance of (say) 2 ohms, that it should be able to drive a speaker. The fact is that it can - provided the speaker has an impedance of more than 2kΩ or so. Since the output current is limited to (usually) no more than around 25mA, it should be apparent that this isn't enough current to drive a loudspeaker.

The output impedance and current drive capability are not related. It's perfectly fine to have a very low output impedance but a low output current, just as it's also fine to have a very high output impedance, but with the ability to drive significant current (such a circuit will also have much higher supply voltages than most opamps can accept without letting out their 'magic smoke'). There are many different possibilities, but this article is based on 'normal' audio frequency circuits. Note that 'audio frequency' doesn't always mean 'audio' per sé, but covers the frequency range from DC up to around 100kHz or so.

None of this is actually difficult once you get your head around the basic concepts. It may seem so at first, but it doesn't take long before you will understand the principles. Datasheets are your best friend, along with Ohm's law. You may be surprised at how much you can do armed only with these two fundamentals.

7 - Baxandall Tone Controls

This is the most common of all modern tone control circuits, and was named after PJ Baxandall who came up with the idea many years ago. The original design article was entitled 'Negative Feedback Tone Control - Independent Variation of Bass and Treble Without Switches', and was published in Wireless World (now Electronics World) in 1952. This type of control is fully symmetrical, and there is very little interaction between the controls, unlike the older passive controls. When centred, there is neither loss nor gain, and the opamp acts as a buffer. Frequency response is absolutely flat, provided the pots centre precisely.

Figure 12
Figure 12 - Modified Baxandall Tone Controls

The circuit is a frequency dependent feedback arrangement, and provides boost and cut for high and low frequencies. It is common for designers to make the turnover frequency for both treble and bass centred around 1kHz, but this is essentially a bad idea (IMO). Ideally, bass boost/cut should start from no higher than about 200Hz, and treble boost/cut should start at no lower than around 2.5kHz. In practice it will be found that this is more natural, and provides the boost where it will do the most good (or harm, for the purists!). 640Hz was used as the 'centre' frequency rather than 1kHz, which is too high. (640Hz is 5 octaves from 20Hz, and 5 octaves (close enough) from 20kHz.)

Figure 12 shows a more or less conventional circuit, with the ±3dB frequencies set to my preferred values. This has the effect of limiting the maximum boost and cut within the audible spectrum to somewhat less than the 20dB often quoted. 20dB is an outrageous amount of control, and far exceeds what is needed for normal system balancing. If 20dB of anything is needed, then I suggest that the system is grossly inadequate, and should be replaced!

The maximum boost is about 14dB, which is still far more than necessary, the lower ±3dB frequency is about 150Hz, and the upper ±3dB frequency is about 2.5kHz. These can be changed by modifying the values of the bass and treble capacitors, and the amount of boost and cut is varied by changing the series resistors for each pot.

This circuit must be driven from a low impedance, so connecting it after the volume control (for example) is a no-no. Ideally, the output of an opamp will be the source, thus ensuring the required low impedance.

Calculation of all frequency characteristics is complex, repetitive and tedious. Fortunately it's not necessary because this is a tone control, not a precision equaliser. The formulae shown here for working out the values for these active tone control circuits are fairly simple, but can be quite inaccurate under some circumstances. At least it will give you a starting point, so the formulae for the bass control lower turnover frequency (fb0 - the frequency where boost or cut starts to level out) and ±3dB frequency (fb3) are (respectively) ....

fb0 = 1 / ( 2 × π × C × Rv ) ... where C is the cap across the pot, and Rv is the pot value
fb3 = 1 / ( 2 × π × C × Rs ) ... where C is the cap, and Rs is the series resistance to the pot

These give (again, respectively) ...

fb0 = 1 / ( 2 × π × 47nF × 100k ) = 33 Hz
fb3 = 1 / ( 2 × π × 47nF × 22k ) = 154 Hz

The treble is a little trickier, since there is a slight interaction with the bass control, due to the bass feed resistance from the bass pot wiper. In theory (ha ha) the frequency is determined by ...

ft = 1 / ( 2 × π × C × Rb ) ... where C is the treble cap (560pF above) and Rb is the bass feed resistor from the pot wiper.

While this seems reasonable, the formula comes up with a frequency of nearly 13kHz, which is obviously wrong. There are series resistances in the entire treble control network, and the interactions are interesting to say the least. In fact, the ±3dB frequency for the treble control changes with the pot setting. For example, at 80% of rotation, treble boost is +3dB at just over 3.5kHz, with a maximum boost of 6.3dB at 20kHz. This may seem to be a bad thing, having the frequency shifting about as the pot is varied, but in practice it works very well. To obtain the results you want, I suggest that experimentation is in order !

A final word about the tone control circuit. Note that it is a 'virtual earth' circuit, so the feedback at all times will maintain the -ve input at zero volts. The bass and treble content of the input waveform will force the amplifier to provide just the amount of boost or cut at any frequency to maintain the 0V condition on -in. You will find this useful as you work towards an understanding of the complete circuit.

8 - Active Filters and Crossovers

The active filter is one of the most common opamp applications after basic amplifiers. There are essentially four different types of filter, but each can be constructed using a myriad of different techniques. I shall only use the most common arrangements, since the complete array is truly mind-boggling. The area of filters is the subject of complete books (from a number of authors) and I cannot hope to cover any but the most common. If you want more on this topic, see the ESP Active Filters article.

Firstly, there are many different possibilities for filters. We shall look at each of the different responses, orders and types before anything else. The filter 'order' gives us essential information about how well (or otherwise) a given filter will reject unwanted frequencies. The standard ones are:

Order | Sections | Nominal Rolloff
First | 1 | 6 dB / Octave
Second | 2 | 12 dB / Octave
Third | 3 | 18 dB / Octave
Fourth | 4 | 24 dB / Octave
"n" | Where n > 4 | 6 dB / Octave / section
Table 1 - Filter Orders

In audio work, the first four are most commonly used, since as the filter order increases, the transient response becomes worse and greater phase disturbances become evident. All filters affect the phase of the signal, and all filters have some effect on transient response. These are unavoidable, regardless of whether the filter uses valves, transistors or opamps, or is completely passive, using only capacitors, resistors and/or inductors.

There are 4 main responses that are obtainable from filters. Some are - or can be - derived from others, so the base types are given first. In particular, band pass and band stop filters can be simple filters with a narrow response (typically used for equalisation circuits), or band pass filters made from a combination of a low frequency high pass filter, followed by a higher frequency low pass section. These are commonly used in crossover networks.

Response | Passes ... | Blocks ...
Low Pass | Low frequencies | High frequencies
High Pass | High frequencies | Low frequencies
Band Pass | Selected frequency | All other frequencies
Band Stop | All other frequencies | Selected frequency
Table 2 - Filter Responses

Low and high pass filters are usually conventional enough, but band pass and band stop filters can be made in many different ways.

Essentially, there are also a few basic filter alignments, which are as follows (not all are included, and many are applicable to filters of more than one section, or more complex arrangements):

Filter Type | Q (Typ) | Characteristics
Bessel | 0.57 | Best time delay
Butterworth | 0.707 | Flattest amplitude
Chebyshev | 0.8 - 1.3 | Fast initial rolloff
Cauer / Elliptical | 0.7 - 1.3 | Very fast initial rolloff
Table 3 - Filter Types

Of the above, the Butterworth is the most common in audio. Although some filter's responses may be closer to Chebyshev, this is commonly more by accident than design. A Chebyshev alignment is very common in acoustical filters (a loudspeaker - box - port combination, for example), but is not generally considered desirable in electronic filters for crossovers or other purposes.

You may have noticed that the Linkwitz-Riley filter was not mentioned in the above table. This is because it is an alignment between filters, and not an alignment type itself. The Linkwitz-Riley filter is a rearrangement of two cascaded 2nd order Butterworth filters, and relies on the characteristics of the two sections (high pass and low pass) to provide the total amplitude and phase response. For example, a 12dB/octave Linkwitz-Riley filter has a Q of 0.5 (sub-Bessel), and the crossover frequencies align at the -6dB frequency rather than the -3dB frequency found with Butterworth filters.

Finally, there are different circuit arrangements that are commonly used in audio to create the filters described above. As you can see by now, the combinations and permutations of all of these different possibilities is immense.

Circuit Type | Gain | Characteristics
Sallen-Key | Unity | Simple design
Equal component value | Depends on Q | Simpler design
Multiple feedback | Depends on Q | Relatively complex
State Variable | Depends on Q | Relatively complex
Biquadratic | Depends on Q | Relatively complex
Passive | < unity | Simple or complex
Table 4 - Circuit Types

This is a condensed listing, and there is some overlap between the topologies in some cases. Indeed, in some cases it is difficult to see any appreciable difference at all. For the sake of simplicity (and to keep this section to a readable length), I shall concentrate on the Sallen-Key filter type, using Butterworth alignment.

Before we go there, we need to define some of the terms you will see. Again, I have kept this list to the minimum for the sake of simplicity, but armed with this knowledge you will be able to understand the circuits and descriptions that follow.

Terms and Definitions

Cascading: Simple filters can be made with one (or no) active devices. As filter orders become greater, it is no longer feasible, so filters use opamps and are joined together in series to obtain the desired response. This complicates the design (often dramatically).
Cutoff Frequency: Also shown as fo, this is the -3dB frequency of the filter, relative to the highest peak (if any exist) in the passband.
Decade: A 10:1 (or 1:10) ratio of frequency. For example 100Hz to 1000Hz is one decade. One decade is approximately 3.16 octaves.
Decibel (dB): The most common way to describe amplitude in audio. The dB scale is logarithmic, and describes the amplitude as we hear it. A 3dB drop in gain equates to half the power in an amplifier.
Quality Factor: Commonly known as Q, this is the inverse of the filter's damping. For example, a Butterworth filter has a Q of 0.707, which equals a damping of 1.414. Higher Q gives more ripple for low and high pass filters, or makes a bandpass or band stop filter more selective.
Octave: A 2:1 (or 1:2) ratio of frequency. For example, 440Hz to 880Hz is one octave (A440 means concert pitch 'A' musical note).
Order: The order of any filter determines its rolloff frequency response. First order filters roll of at 6dB per octave (20dB/ decade), and as the order increases, so too does the rolloff rate. An additional 6dB / octave is gained for each additional order, starting from first. A 3rd order filter will therefore roll off at 18dB /octave, for example.

In addition to the above, you'll often see filters described as (for example) 4-pole, which means that the filter has 4 effective 'sections' that create the rolloff slope. A 4-pole filter is the same as a 4th order filter. Some filters include one or more 'zeros' in the response. A zero is effectively the opposite of a pole, and is used to limit the ultimate boost or attenuation provided by a filter. For example, including a resistor in series with the capacitor in Figure 13 or in parallel with the cap in Figure 14 will introduce a zero and limits the maximum attenuation. As this is not easy to get your head around initially, I won't take it any further here.

8.1 - Designing Our First Filter

The first active filter must be the first order low pass. By simply reversing the filter components, this becomes a first order high pass. In each case, the filter only consists of the resistance and capacitance, with the opamp simply isolating the filter from the following stages. Q is not variable in a first order filter, and the only options are high pass and low pass. A bandpass filter can only be created by cascading a high and low pass filter. Although the least useful of all filters, they are easy to understand, so make a good starting point.

Figure 13
Figure 13 - 1st Order Low Pass Filter

As you can see, at low frequencies, the capacitor has little effect on the signal, which is simply passed through the resistance and buffered by the opamp. As the frequency increases, the capacitor will shunt more and more of the signal to earth, until at very high frequencies, no appreciable amount of the signal is passed. As the capacitor's reactance becomes significant with respect to the resistance, the signal will be subjected to a phase shift as well as reduction in amplitude. When the capacitive reactance is equal to the resistance, the amplitude will be 3dB lower than at low frequencies.

Rc = 1 / ( 2 × π × f × C ) ... where Rc is capacitive reactance

This is the cutoff frequency of the filter, and is determined with the formula ...

fo = 1 / ( 2 × π × R × C ) commonly shown simply as ...
fo = 1 / ( 2 π R C )

Note that the input of this filter must have a low impedance return to earth at the input, or the opamp will not have any bias current or voltage, and will not work. This rule applies to low pass filters in all cases without exception. Any appreciable source impedance will also change the frequency, as the impedance is effectively in series with R1. This also applies to the high pass version shown next. In this context, 'appreciable' means any impedance of equal to or greater than 1/10th of the filter's impedance. For example, with a 10k resistor, 1k is 'appreciable'. Even a source impedance of 100 ohms will change the frequency slightly.

For the filter in Figure 13, the frequency is determined by ...

fo = 1 / ( 2 × π × 10k × 100nF ) = 159 Hz
Rc = 1 / ( 2 × π × 159 × 100nF ) = 10k ohms

By reversing the positions of R and C, we obtain a high pass filter. The formula remains the same, and the two filters will have a complementary response centred at the 159Hz frequency. There is no need for an earth return at the input for a high pass section, as this is provided by the resistor.

Figure 14
Figure 14 - 1st Order High Pass Filter

In their simplest forms, these two filter sections are also known as integrators (low pass) and differentiators (high pass). This is of some consequence, as these terms are commonly used in electronics.

A bandpass filter is created by cascading a high pass and a low pass, as shown in Figure 15. An opamp may be used in between the two sections to prevent any interaction. As shown, it is also possible to scale the first filter so that interaction is minimised. This works well enough in practice to be a useful technique. Scaling merely means that the ratio of values remains the same, but the resistance is reduced and the capacitance increased to make a lower impedance filter with the same characteristics. The generally accepted scaling factor is one decade (an 'order of magnitude', or a 1:10 ratio). For Figure 15, I simply selected the lowest sensible resistor value of 1k, and the capacitor was chosen more or less at random to give an acceptable graph of the response.

Figure 15
Figure 15 - Scaled Cascaded Bandpass Filter Saves One Opamp

In reality, it may be found that the value of capacitance becomes so great that the capacitor will be more expensive than a section of an opamp. Alternatively, the resistance may become so low that no opamp can drive the load. It is essential to ensure that impedances are within the acceptable range for the opamps used. Generally, impedances of less than 1k at any frequency are not recommended. For noise considerations, very high resistance values are also not recommended, and I suggest that 100k is a reasonable compromise. There will be occasions where this is not practicable and higher values may be the only sensible solution, but these should be few and far between.

If the high pass section of Figure 15 is verified by calculation, it is discovered that the cutoff frequency (Fo) should be 7234Hz, and not 6400Hz as shown. The difference is caused because the second filter loads the first, shifting the frequency. This is a very good reason to isolate the sections using an opamp.

8.2 - Component Selection

All following filter sections will use resistance within the range of 1k to 100k. This gives two decades of freedom, and this is more than enough to allow capacitors of sensible sizes to be used. Very low capacitance values are to be avoided, since the capacitance of wiring (PCB tracks etc.) will modify the filter characteristics to a possibly unacceptable degree. I generally try to keep capacitance above 1nF wherever possible, and this may save you some grief as we progress. Likewise, any capacitance above 1µF becomes large and relatively expensive, but within this range we also have two decades of freedom, and there is virtually no audio filter that cannot be designed within these constraints.

Generally, it is sensible to select the capacitor value first, as these have less available values within a decade than resistors. Capacitors have 12 values per decade (the E12 series), while resistors have up to 96 values per decade (E96 series). The latter are not usually easy to get, but the E24 series is now very common, and has (surprise!) 24 values per decade. The E12 and E24 series are shown in Table 5.

E12 | 1.0 |  | 1.2 |  | 1.5 |  | 1.8 |  | 2.2 |  | 2.7 |  | 3.3 |  | 3.9 |  | 4.7 |  | 5.6 |  | 6.8 |  | 8.2 |
E24 | 1.0 | 1.1 | 1.2 | 1.3 | 1.5 | 1.6 | 1.8 | 2.0 | 2.2 | 2.4 | 2.7 | 3.0 | 3.3 | 3.6 | 3.9 | 4.3 | 4.7 | 5.1 | 5.6 | 6.2 | 6.8 | 7.5 | 8.2 | 9.1
Table 5 - E12 and E24 Component Values

These values are multiplied or divided as needed for any decade range from 0.1 Ohm up to 10M Ohms, and from 10pF up to 10µF. Generally it will be found that at the extremes of the ranges (such as from 10pF to 100pF), most stockists do not have the full range of values. This is another good reason to stay within reasonable limits for all component values wherever possible - not just for filter designs.

8.3 - Second Order Filters

Note that all response graphs shown in this section cover the frequency range from 10Hz to 10kHz, and all but the Chebyshev response are from 0dB to -20dB (the Chebyshev is from +10dB to -20dB). The reference input voltage is 1V RMS, or 0dBU.

By using multiple feedback paths, a second order filter can now be designed. These are the first genuinely useful filters for crossovers and the like, and are the most commonly used in both electronic and passive crossover networks. There are some unpleasant side effects to the second order high and low pass filters, but this has never stopped anyone from using them. As we shall see, these effects can be cancelled to some extent, but unless exotic configurations are used you can never get phase coherency.

A phase coherent filter gives the design some special characteristics that are extremely useful in audio. This simply means that at any frequency within the pass band or stop band of either filter, the output signal from each is in phase, preventing any peaks or dips in the combined response. These will be covered in more detail a little later.

Of all the topologies available, I will concentrate on the Sallen-Key (also known as unity gain) Butterworth filter. The equal component value filter is useful in some areas, but is a nuisance because of the gain that each section adds. This is sometimes useful, but mostly is not necessary, and the filter section needs more components. They are easier to design, but the difference is slight, and often the resistor needed to set the gain precisely will work out to be impossible to obtain. For the values I am using, a 14.414k resistor would be needed, which as you can see from Table 5 is not a standard value.

Figure 16
Figure 16 - Second Order Unity Gain Low Pass Filter

As you can see, the opamp is used only as a buffer, contributing no gain. For Butterworth alignment, the component values are as shown. The filter can be made into anything from Bessel to Chebyshev by changing the component values about, but these other alignments are not generally as useful in audio work.

If R has been selected first, the capacitor values for C1 and C2 are chosen from the equations ...

C1 = 4 / d² × C2 = 2 × C2 ... where d = 1 / Q
C2 = 0.707 / ( 2 × π × F × R )

The formula for calculating the value of C1 only applies to a Butterworth filter. Of course if you were to follow my advice from above and select the capacitance first, you need a different formula ...

R1 = 0.707 / ( 2 × π × F × C2 )

Again, the equation for resistance or capacitance for each example only works for Butterworth filters! For a Q of 0.707 or damping of 1.414 (Butterworth) it works out that C1 is exactly double the value of C2. R1 and R2 must be equal in value, or the filter's response will be something other than that desired.

Note Carefully Note: Any change of Q by varying the resistance ratio or capacitor ratio also changes the frequency. The formulae become quite complex, and I am not going into further detail.

For example, if the C1 is four times as great as C2, this creates a Chebyshev filter with a Q of 1, as shown in Figure 17 for the sake of example. Equal capacitor values would be used for a 'sub-Bessel' alignment with a Q of 0.5 - the possibilities are endless, as I am sure you can now appreciate.

Figure 17
Figure 17 - Second Order Chebyshev Filter

The filter of Figure 17 clearly shows the peaking obtained from a Chebyshev filter. The peak amplitude is +1.25dB from the nominal 0dB value, and the cutoff frequency is determined to be 3dB below this maximum. I remain unconvinced that this is the right way to measure the cutoff frequency - I think I prefer to use the 'genuine' -3dB point. Either way, the cutoff frequency is not easy to calculate, and although it would be no great strain for me to give you all the equations, I doubt that you would want to know!

The high pass equivalent of the Butterworth low pass filter is shown in Figure 18, and as you can see is a re-arrangement of the other design. Frequency is the same as for the low pass filter, but note that now C1 and C2 are the same value, and R2 is double the value of R1. Frequency is calculated on C1 and R1, and it is easy to become confused when designing the circuits just which values determine the frequency.

In both cases it is nearly always easier to use paralleled capacitors and series resistors as I have shown, since these will be more accurate than simply doubling (or halving) the values - especially so since the standard values do not always have exact double or half values. Any variation of these values will shift the response away from Butterworth and towards either Bessel or Chebyshev responses, and will change the frequency.

Figure 18
Figure 18 - Second Order Unity Gain High Pass Filter

Second order filters can also be used for bandpass and band stop, but are generally of limited use in audio circuits. They are sometimes used as equalisation circuits, and indeed the simple inductor / capacitor (LC) filters shown in Figure 8 are 2nd order types. A second order filter requires that there are two reactive elements, with an filter LC there is the capacitance and the inductance, and with an active filter there are two capacitors.

8.4 - Crossover Networks

When combined, high pass and low pass filters are commonly used to create electronic crossover networks. There are many different ways to do this, but the most common is still the second order Butterworth filter. Although these are essentially at least as good as the passive speaker level counterpart (but not all that much better), the results are often vastly superior. The reasons for this are discussed at great length in my article Bi-Amplification - Not Quite Magic (but Close) and I shall not repeat them here.

In a nutshell, using an electronic crossover eliminates many of the problems that beset loudspeaker designers when they have to design and build the crossover network. The passive crossover is influenced by any aberration in the driver's impedance, especially at or near the crossover frequency. Since the electronic crossover supplies the signal to a separate amplifier for each frequency band, there is no interaction and each amp only needs to be concerned with a much smaller bandwidth.

All crossover networks are a combination of high pass and low pass filters, although this is not always achieved in the same way. Some crossovers use an opamp as a subtracting amplifier, so rather than using a separate filter, the bass (for example) is subtracted from the main signal to provide the midrange and high frequency. Alternatively, the mid+high output from the filter is subtracted from the main signal to separate the bass, and this configuration is shown below. These crossovers are phase coherent (both outputs are always in phase at any frequency), but are asymmetrical. A typical design is shown in Figure 19, and the response clearly shows that the high pass rolloff is 12dB/octave, but the low pass is only 6dB/octave.

Figure 19
Figure 19 - Subtractive Electronic Crossover

Although these networks can be capable of acceptable results for non-critical applications, great care is needed to ensure that the driver getting the 6dB/octave rolloff can handle the increased power levels created by such a low rolloff rate. Notice that the LF rolloff peaks, and that the crossover frequency does not coincide with the actual -3dB frequency of the high pass section. Although this looks really bad, because of the phase differences the combined frequency response is completely flat. With loudspeaker drivers this will often not be the case, especially when listening off axis. Because of this, the subtracting crossover is really only useful where the system is not used for 'critical listening'. I have never been a fan of this type of crossover, but the circuit is interesting and shows the versatility of opamps. Basically, I do not suggest or recommend subtractive crossovers for anything other than experimentation.

Rather than show a multitude of crossover designs here, you can look at the Projects Pages to see a suitable sampling of crossover networks. Of these, the 24dB/octave Linkwitz-Riley is by far the best, and is highly recommended.

Notice the cunning way I introduced a new opamp configuration - the subtracting (or difference) amplifier. This (and other useful topologies) will be discussed in greater detail a little later.

8.5 - Band Pass Filters

The band pass filter (as a single filter) is not normally very useful in audio reproduction. The frequency range passed is too narrow to be useful for anything other than equalisation circuits, or for test and analysis equipment. Having said this, there are many uses for bandpass filters that are very common in the production of music - the synthesiser, guitar wah-wah pedals, Vocoder, etc.

The range is far too great to cover in any real detail, but we can at least look at the fundamental principles, as these are common to all of the applications. The two most common parameters quoted for bandpass filters are frequency (fo) and Q (quality factor). The latter may be inverted and referred to as damping.

A simple bandpass filter consisting of two reactive elements has an ultimate rolloff of 6dB/octave. When one looks at resonance, the slope may appear to be much greater than this, which is fair and reasonable, since it often is. Eventually, the high slope due to resonance effects cannot be maintained, and the final slope is at 6dB/octave, as shown in Figure 20. But wait! This is an article about opamp designs, and there is no opamp there, just a stupid inductor and capacitor. True, but we need to be able to understand the concept of resonance before delving into the opamp version of the circuit.

Active (using opamps or transistor circuits) bandpass and band-stop filters can be created easily, and are covered the ESP Active Filters article. As this is an introduction, only the basics are shown here.

Parallel resonance is shown first, and it will be apparent that the series resistor is 1k, but only 100 ohms for the series circuit shown further below. This was done so that the two response graphs could show the full effect. The way any resonant circuit is configured depends on what you are trying to achieve, and these are only examples, not 'real world' circuits.

Figure 20
Figure 20 - Parallel Resonant Circuit

There are essentially two forms of resonant circuit - series and parallel. When only passive components are used (resistor, inductor and capacitor), the series resonant circuit has minimum impedance at resonance, and the parallel resonant circuit has maximum impedance. The formula is actually slightly different for each (the resistance of the coil changes the resonant frequency slightly in a parallel resonant circuit), but for all intents and purposes the following formula can be used with little error ....

fo = 1 / ( 2 × π × √LC )

Where fo is resonant frequency, L is inductance in Henrys and C is capacitance in Farads. Any error caused by the series resistance of the coil will generally be less than that caused by component tolerance. For example, if the coil shown in Figure 20 has a winding resistance of 10 ohms, the resonant frequency in increased by less than 1Hz.

The resonant frequency is that where the capacitive and inductive reactances are equal. In the example of Figure 20, only when Xc (capacitive reactance) and Xl (inductive reactance) are the same will the circuit be at resonance. Below resonance, the inductive reactance decreases, and shunts more of the signal to earth. Above resonance, the capacitor will be responsible for shunting the signal to earth. Since in each case there is the resistance and a single capacitor or inductor to bypass the signal, this is a single pole filter and will have 6dB/octave rolloff. As shown, the reactances at resonance are one tenth of the series resistance, so the filter has a Q of 10, but the final rolloff slope is 6dB/octave. The initial slope is increased by increasing the series resistance (and thus the Q of the circuit), but eventually the rolloff will go back to 6dB/octave.

Series resonance is especially interesting. At resonance, the circuit is almost a short circuit, so the input signal will be heavily loaded. At the junction of the inductor and capacitor there may be a voltage that is many times that at the input. This effect is described below. If enough current is available, incredibly high voltages may be obtained, and great care is needed to ensure that the voltage rating of the components is sufficiently high to withstand the voltage. Since the laws of physics and the taxman dictate that we cannot get something for nothing, the available current is very limited at the high voltage point. A circuit with a very high Q will generate much greater voltages than a circuit with low Q. The voltage magnification is equal to the Q of the circuit.

With the component values as shown in Figure 21, the voltage at the output will be about 0.5 mV at resonance, but there will be 1V across both the inductor and capacitor. At resonance, the reactance of the capacitor and inductor are equal and opposite, so the circuit will appear to be almost a short circuit - input current is limited only by the wiring resistances and source impedance. Series resonance is a somewhat 'special' case, and it may take some time before it makes sense to you.

The maximum possible Q of an LC filter is dictated by the series resistance of the inductor. The Q may be reduced by adding resistance, but cannot be increased. The circuit Q is determined by the reactance of the cap or coil at resonance and the series resistance. Q of a parallel resonant circuit is increased by increasing the series resistance, and the Q of a series resonant circuit is increased by decreasing the series resistance.

Figure 21
Figure 21 - Series Resonant Circuit

At very high frequencies, the so-called 'skin effect' increases the apparent resistance of the inductor. The skin effect is where the electrons tend to want to occupy the outer section of the wire and are not evenly spread through the conductor. This gets progressively worse as the frequency increases. Likewise, the dielectric absorption of capacitors reduces their efficiency and lowers the overall Q. We shall not investigate these effects further, since they are unrelated to audio frequencies generally, and especially to opamps.

A quick word about Q. In both cases above, resonance is at 159Hz. The reactance of both the inductor (Xl) or capacitor (Xc) at this frequency is 100 ohms, so with a 1k series resistance (parallel resonance) or 10 ohm series resistance (series resonance), the circuit Q will be 10. Resonance is defined as that frequency where the capacitive and inductive reactances are equal. The reactance can be calculated from ....

Xc = 1 / ( 2 × π × f × C )
Xl = 2 × π × f × L

This basic understanding of the ratios is essential in the design of bandpass and band stop filters, and is also very much a part of the design process for passive loudspeaker crossover networks. The latter have absolutely nothing to do with opamps, but I just thought I'd mention it [image].

The Q of a resonant circuit determines its bandwidth. With a Q of 10, bandwidth of our bandpass filter above is 15.9Hz. This places the -3dB frequencies at 151Hz and 167Hz (near enough), so it is apparent that the range of frequencies allowed through is very limited. In practical audio work, this is far too narrow to be useful, so lower Qs are far more common. This is fortunate, because high Q opamp bandpass filters are difficult to design, and require opamps with very high bandwidth for proper operation at the upper end of the audio band.

Band-stop filters (aka notch filters) made using a series resonant circuit have a theoretically infinite notch depth, but this is never achieved in practice because of circuit resistance (inductor resistance, wiring resistances, etc.). Even a moderate Q can provide a narrow notch as seen in Figure 21. The Q is unity, so the -3dB frequencies for the notch are at 98Hz and 258Hz, but the notch depth may be greater than 60dB.


Vu dans ... https://monster.partyhat.co/article/amplifier-tone-stacks/

Table of Contents

  • Overview
  • One Knob Tone Controls
    • Tweed Princeton
    • Moonlight
    • Garnet
    • 18 Watt
  • Two-Knob
    • Fender “Brownface”
    • Blonde Twin
    • Baxandall
      • Baxandall Mid Boost
  • Three Knob
    • Fender/Marshall/Vox
    • Dumble
  • Other

Overview

This is a collection of common guitar amp tone stack schematics and layouts. Some of these (Tweed, Moonlight, FMV, Baxandall) I’ve built, and some I haven’t. Most of the information here has been gathered from many sources, primarily the AX84 and Ampage message boards, and of course reading over far too many obscure schematics in search of alternatives.

One Knob Tone Controls

Tweed Princeton

The first tone control I tried in the Lunch Box was a Fender Tweed Princeton-style single tone control (e.g. from 5F2-A). I ended up removing it entirely because I didn’t like it much. The volume & tone controls are too interactive for my taste.

5F2-A Tone Control Schematic

5F2-A Layout

Moonlight

Here is Simcha Delft’s Moonlight tone control. I like this much more than the basic Fender Tweed Champ style single-knob tone control. The tone & volume knobs are more independent of each other, and it’s not as bright as the standard Tweed circuit is. Presented below are the schematic, and a layout diagram for building the tone control on a push-pull pot to include DPDT bypass. Insertion loss is relatively low (at least compared to a standard 3-knob tone stack).

Moonlight Tone Control Schematic

Moonlight Layout

moonlight push/pull layout with bypass

Moonlight Tone Control push/pull layout with Bypass

Garnet

This cool little circuit was posted by Bruce McCabe on the AX84 BBS, lifted from an old Garnet amp. With the tone pot placed in a local feedback loop, it should have a wide range of control.

It also came up again in a thread on low-insertion loss tone controls. Sean K. has built built a variation using a rotary switch to change capacitor values. That should provide a lot of tonal possibilities with a simple circuit and low insertion loss. This would be an interesting tone control to try in the Micro Champ.

The Gibson GA-30RVT also uses this tone control on both of its channels.

18 Watt

Marshall 18 Watt Tone Control Schematic

Marshall 18 Watt Tone Control Layout

Two-Knob

Fender “Brownface”

Fender “Brownface” amps featured some of their most interesting circuits, IMHO. In between the tweed & the blackface amps, the Champs, Princetons, and Deluxes had Tweed-style single knob tone controls. The Brownface Pro and Bandmaster had a two knob treble/bass tone stack which is somewhat different than the 2-knob variation of the Fender blackface tone stack.

The 350K pot tapped at 70K used by the 6G5-A is available again from Weber.

Fender Pro 6G5 or 6G7 tone stack layout

Fender Pro 6G5 or 6G7 tone stack

Fender Pro 6G5-A tone stack

NOTE: The 6G5 uses a de-coupling cap (0.05uF) inbetween the plate of the preceding triode stage and the tone stack, while the 6G5-A does not. The 6G5-A variation is also used on the Normal channel of the 6G6 Blonde Bassman (and 6G6-A) while the Bass channel has what looks like a Blackface tonestack with only a Bass knob, and the6G12 Concert.

Blonde Twin

From about the same era as the Brownface amps is the Fender Blonde Twin, which has a tone stack very similar to the Baxandall stack. In fact, the only difference really is with the treble pot.

Fender 6G8 tone stack

Baxandall

The Baxandall tone stack (also known as James) is a classic circuit more commonly found in hi-fi designs. I’ve used it with pleasing results in 3 amps now. It’s also been used in some commercial guitar amps, such as the Orange 120 MKII. Magnatone used it in a whole series of amps – the 260-A, M10-A, 460, and 480. Some of Ampeg’s Portaflex amps (e.g. B-15-NF) use it as well. This tone stack is featured in Duncan Amp’s Tone Stack Calculator in slightly modified form under the name “James”. Insertion loss is lower than the standard Fender tone stack, but obviously higher than 1 knob controls.

Here's an in-depth analysis of it.

Presented below are the schematic and 2 layout diagrams. The first is for building the stack on 2 normal pots. The second is for building it on a dual-concentric pot.

In the final revision of the Lunch Box, this tone stack is driven by an IRF820 MOSFET source follower. Like a tube cathode follower, the source follower lowers the driving impedance to drive the tone stack with less signal loss. For more, see Mike Donovan’s article on High Voltage Solid-State Circuits for Guitar Amplifiers, or R.G. Keen’sMOSFET Follies.

General consensus seems to be that’s very flexible, but tends to work better in low-gain amps.

Passive Baxandall Tone Stack Schematic

Layout on 2 Standard Pots

Layout on a single dual-concentric pot

Baxandall Mid Boost

I had an unused space for another switch on the front panel, so I added a tiny modification to change the frequency response of the tone stack. It simply parallels a 560pF capacitor with the 330pF treble cap. The effect of this is to add a pronounced midrange “hump” with the tone controls flat, and a lessening of the scoop with both controls all the way up. It’s a very simple and effective mod. The effect is centered around 250-450 Hz, depending on the position of the controls. By additionally paralleling another 180K resistor to make 90K between the Bass & Treble pots you can change that to 300-700 Hz.

  • Mid boost sample (MP3)

Three Knob

Fender/Marshall/Vox

This is the classic 3 knob tone stack used (in assorted variations) in so many classic amps. Tried and true, it has fairly high gain loss and big mid scoop. Like any tone stack, its response characteristics can be drastically altered with differing impedances and component values. This is simulated in Duncan Amps’ Tone Stack Calculator.

There are numerous minor variations to this circuit. Some leave out the Mid control, replacing it with a fixed resistor. In others, C3 is wired to the wiper of the Mid control, which is wired as a voltage divider instead of a variable resistor.

Basic Tone Stack Schematic

Basic Tone Stack Layout

Dumble

The Dumble tone stack is basically an Fender/Marshall tone stack with lots of switches added which shift the frequency response in various ways.


Vu dans ... http://www.learnabout-electronics.org/Amplifiers/amplifiers42.php

Amplifier Controls

Fig. 4.2.1 Simple Tone Control

Tone Control

Tone Control, shown in its most basic form in Fig. 4.2.1 provides a simple means of regulating the amount of higher frequencies present in the output signal fed to the loudspeakers. a simple method of achieving this is to place a variable CR network between the voltage amplifier and the power amplifier stages, The value of C1 is chosen to pass the higher audio frequencies, this has the effect of progressively reducing the higher frequencies as the variable resistor slider is adjusted towards the bottom end of the tone control, The minimum level of attenuation of the higher (treble) frequencies is limited by R1, which prevents C1 being connected directly to ground. As the circuit only reduces the high frequency content of the signal it could be called a simple Treble Cut control. The use of these simple circuits is normally restricted to guitar applications or inexpensive radios.

In hi-fi amplifiers, tone control refers to the boosting or reduction of particular audio frequencies. This may be done to suit the preferences of the listener, not everyone perceives sound in exactly the same way, for example the frequency response of the human ear changes with age. The room or hall in which the sound is reproduced will also affect the nature of the sound. many techniques are used to alter the sound, and in particular the frequency response of the amplifiers producing the sound. These range from simple RC filters, through passive and active frequency control networks to complex digital signal processing.

The Baxandall Tone Control Circuit

Fig. 4.2.2 Baxandall Tone Control Circuit

The circuit discussed here is an example of the Baxandall tone control circuit, illustrated in Fig. 4.2.2, which is an analogue circuit providing independent control of bass and treble frequencies; both bass and treble can be boosted or cut and with both controls at their mid positions, provides a relatively flat frequency response, as illustrated by the blue ‘Level response’ graph line in Fig. 4.2.5. The original design, proposed by P. J. Baxandall in 1952, used a valve (tube) amplifier and feedback as part of the circuit to reduce the considerable attenuation (about −20dB) introduced by the passive network, and to provide true bass and treble boost. There are still many variants of the circuit in use, both as active circuits (with amplification as originally proposed), and as passive networks without an incorporated amplifier. In passive variants of the Baxandall circuit, extra stages of amplification may be used to make up for the approximately −20bB attenuation caused by the circuit.

Read the original 1952 paper "Negative-Feedback Tone Control" by P. J. Baxandall B.Sc.(Eng.) published in "Wireless World" (Now Electronics World)

How the Baxandall Circuit Works.

Fig. 4.2.3 Maximum Bass & Treble Boost

With bass and treble controls set to maximum boost (both wipers at the top of resistors VR1 and VR2), and the inactive components greyed out, the circuit will look like Fig. 4.2.3. Both bass and treble potentiometers that may have either linear or logarithmic tracks depending on the circuit design, are much higher values than other components in the circuit, and so with the VR1 and VR2 wipers set to maximum resistance both potentiometers can be considered to be open circuit. Nor does C4 contribute to the operation of the circuit because of the high resistance of VR2, and C1 is effectively shorted out by the wiper of VR1 being at the top end of its resistance track.

The full bandwidth of signal frequencies is applied to the input from an amplifier having low output impedance, and the higher frequency components of the signal are fed directly to the output of the tone control circuit via the 2.2nF capacitor C3, which has a reactance of about 3.6KΩ at 20kHz but over 3.6MΩ at 20Hz, so blocks the lower frequencies.

The full band of frequencies also appear at the junction of R1 and C2, which together form a low pass filter with a corner frequency of around 70 to 75 Hz and so frequencies appreciably higher than this (the mid and high frequencies) are conducted to ground via R2.

Having R2 in series with C2 prevents the attenuation of the mid band frequencies exceeding about -20dB. The lower frequencies are fed to the output via R3. Because R3 has quite a large value (to effectively isolate the effects of the two variable controls from each other, the input impedance (Zin) of the circuit following the tone control must be very high to avoid excessive signal loss due to the potential divider effect of R3 and the Zin of the following stage.

Bass and Treble Cut.

Fig. 4.2.4 The Circuit with VR1 and VR2 at Minimum

With the bass and treble controls both set to maximum cut (Fig. 4.2.4), the full bandwidth signal passes through R1 but with the slider of VR1 at the bottom end of its resistance track, C1/R2 now form a high pass filter having a corner frequency of around 7 to 7.5kHz so only frequencies appreciably higher than this are allowed to pass un-attenuated. The mid and higher frequencies are therefore fed to R3 and C4, which now form a low pass filter to progressively attenuate frequencies above about 70 Hz, the mid-band frequencies (about 600Hz) are reduced by approximately −20dB, and at 20kHz by as much as −43dB, as can be seen from the response curve in Fig 4.2.5.

Fig. 4.2.5 The Baxandall Modified Response Curve

Notice that although the circuit provides what is called bass boost and treble boost, with the passive version of the Baxandall circuit (with no amplification), all frequencies are in fact reduced.

The attenuation of the circuit at mid-band is typically around −20dB and with full ‘boost’ applied at either the low or high end of the bandwidth, attenuation at these frequencies would be around −1 to −3dB.

Active Baxandall Circuit

To overcome the substantial losses in the passive version of this circuit, which give a level response (with both controls at mid way setting) but at -20dB below the input voltage, it is common to incorporate an amplifier in the designs. Nowadays an op-amp would be a reasonable choice, with the Baxandall network forming a negative feedback loop to give the required gain figures over the necessary bandwidth. Various designs are possible with different values for resistors R1 to R4 and C1 to C4 in the network, depending to some extent on the output impedance of the previous, and input impedance of the following circuits.

With active circuits such as that shown in Fig. 4.2.6 the aim is to have the level response at 0dB so there is no gain and no loss due to the tone control circuit. The maximum amount of boost possible should not be sufficient to overload any stage following the tone control if distortion is to be avoided. The design of such control circuits is usually therefore, an integral part of the overall design of an amplifier system.

Fig. 4.2.6 An active tone control using a Baxandall network and op-amp with NFB.

Tone Control ICs

Fig. 4.2.7 The LM1036 Audio Control IC

In modern amplifiers the tendency is to use integrated circuit controls that may be operated by either digital or analogue circuitry. A simple solution for bass, treble, balance and volume control in analogue stereo amplifiers is offered by such chips as the LM1036 from National Instruments.

The block diagram and an application circuit is shown in Fig. 4.2.7. Each of the four controls is adjusted by applying a variable voltage of between 5.4V (which is supplied by pin 17 of the IC), and 0V. Half the voltage applied to the control pins 4, 9, 12 and 14 gives a level frequency response, central balance between left and right channels, and half volume.

The LM1036 also has provision for a loudness compensation switch. When ‘on’ this changes the action of the controls to boost the bass and treble frequencies when the volume is at a low setting. The purpose of this is to compensate for the fall off in the function of human hearing at high and low frequencies with quiet sounds.


Accueil

Accueil CHM

Normal, dit comme ça,
vous ne risquez pas de comprendre.


PREAMPLI-MIXAGE-4-MICROS

CORRECTEUR de TONALITE

Ampliier HF

Préampli mixage 4 micros

Pré-ampli-phono-RCA-7025

PRAMPLI-STEREO-12AU7-ECF80

PREAMPLI-MIXER-BOUYER-311-1 à Transistors

Mixage 4 preamplis EF86

Pré-ampli RIAA

Pré-amplificateur avec contrôle de tonalité


préampli

Vu dans ... http://radio-retro.fr/Preampli.htm

Le Préampli

Destiné à attaquer l'ampli PushPull EL 34 décrit dans ces pages.

Le but final étant de sonoriser un clavier midi, un instrument de musique, (guitare, clavier, ainsi que d'autres applications BF, les correcteurs d'entrée sont simples et sans fioriture inutile style correcteur RIAA.

Le schéma: Il est inspiré par différentes lectures, le filtre de correction de tonalité (graves-medium-aigües) a été calculé au simulateur Tone-Stack Calculator V1.3.0.36. de Duncans (http://www.duncanamps.com/software.html) sur la base du montage des amplis Marshall.

Les tubes EF86 ont été choisis pour leur gain important, et leur faible souffle.

Le circuit imprimé a été dessiné sur CorelDraw, un logiciel de dessin non dédié à l'électronique, n'ayant pas l'opportunité d'utiliser un logiciel lourd de traçage de circuits-imprimés, et dont l'utilité est contestable pour moi, ayant seulement quelques circuits à réaliser à l'unité par an.

J'utilise CorelDraw depuis de nombresuses années, et j'ai créé une bibliothèque de composants standards, et égalements de ceux qui présentent des formes et des cotes particulières.

Avant de dessiner le circuit imprimé, je réunis au préalable tous les composants. De la sorte, je suis sûr de l'encombrement et de l'écartement des divers éléments, qui sont variables selon les sources d'approvisionnement.

Le tracé se fait d'après le schéma, après avoir déterminé l'implantation des composants essentiels tels que les tubes, les potentiomètres etc... Les longueurs pour les liaisons signal sont minimisées, et inversement les plans de masse sont généreusement renforcés.

En fait, une fois les liaisons réalisées, je comble un maximum d'espace vide par des lignes de masses ce qui ne peut qu'être bénéfique pour le signal, et aussi ce qui facilite la gravure du circuit imprimé (moins de cuivre à enlever).

A l'heure où ces lignes sont écrites, (février 2003), la mise sous tension n'a pas encore été faite pour cause d'indisponibilité d'utilisation de local de bricolage. L'opération est remise en mars-avril, et je compléterai ces lignes avec les résultats obtenus. ... à suivre...